Ray Kholodovsky I have attached pictures mentioned in the comment to this post:

@raykholo I have attached pictures mentioned in the comment to this post: https://plus.google.com/+RayKholodovsky/posts/So8wMFFUGkQ
Pic. 1 (widget) and pic. 2 (Eagle) is the Top layer.
Pic 3 (widget) and pic. 4 (Eagle) is the Bottom layer.
Pic5 is the Eagle Top + Bottom displayed together, probably not needed here.

This is just a screenshot and the quality is not perfect when resizing picture preview, but you may see that some traces are overlapped with pads or other traces.

@sszafran thanks for the snapshots. I don’t see any traces overlapping. I do see the blue outlines around them overlapping. Set the inflation distance from 0.35 to something smaller like 0.15 and try again. Let me know if it persists.

The bottom layer is missing all it’s pads.

That part is still a work in progress. I can render the bottom pads in my code but they are not getting rotated.

I also noticed that round smd pads are square at the moment. I know you are still working on it. I just wanted to let you know in case you didn’t see it yet.

@Mano_Biletsky_Open_M Can you show me a picture of where this is happening please? Thank you!

@raykholo ​ here you go:
https://plus.google.com/+ManoBiletsky/posts/8driigxCZMN

@raykholo ​ Right, I used default inflate value of 0.35 previously. Today I rendered both Top and Bottom layers with 0.15 inflate milling path and it looks really nice. I was using release 4 this time. Time to give it a test on CNC, at least the Top layer.