Problems cutting arcs on Longsworth Chuck

(Don Kleinschnitz Jr.) #1

During the cnc build of a Longsworth chuck I ran into a cutting error that is baffling me.


I test cut this job some time ago and it worked fine.

I got a face plate and a new bit for plywood, made some mods to the design to “optomiz” the CAM. I also changed to a larger and better bit (1/4") and best I can tell that is when this problem started. Then I proceeded to cut the final material.

The problem:
On the second arc it cuts the clockwise (G2) arc fine and then on the return (G3) it cuts a straight line vs returning on the same arcs path.

It cuts the center area (for face-plate) and the first arc fine. While cutting the second arc, on the first CCW arc it does not follow the arc, but rather a straight line back to its starting position. Subsequent arcs have similar albeit more complex forms of the same problem.

Its as if when cutting the second arc instead of a G3 move it just makes a linear move back to the start.

Consider:

  1. It used to work…
  2. It makes the center clearing cuts (which are arcs) and the first large arc ok, these are G2-3 cuts.
  3. I haven’t changed the machine or the driving software
  4. I did change some CAM parameters and the bit size
  5. I glanced at the Gcode and I don’t see anything obvious yet, however its complex.
  6. All of the simulations that I have run with 3 different software’s do not show this error. Everything looks fine.

Answers to these questions would be helpful?

  1. Chilipeper does not follow the arc during a simulation of this job is this normal? Note: It does follow the arc path during actual cutting.
  2. Does anyone know of a bug or incompatibility that could be causing this. I reviewed all the tinyg supported codes.
  3. Ideas for troubleshooting???

My plans:

  1. Dig into the Gcode in detail looking for a bug in the code although I have never dissected G2-G3 before :(!
  2. Separate the arcs into separate gcode files and just run the second arc, to simplify things.
  3. Go back to earlier versions and compare. This is tough as all the simulation tools do not show any problem.

Configuration:

  • OX CNC
  • tinyG controller
  • Chilipepper driver
  • Design/CAD in Fusions 360

My album for this project is here

(Grant Le Sueur) #2

Hello Don

Im not very experienced with Arcs per se, but I do recall seeing a post or hearing a comment from John that the simulator does not simulate Arcs.

I am using a tiny g on my machine and would be happy to run the code on my set up to see if I can reproduce the issue.

Not sure the file is too large to post here if you want you can email it to me to give it a try this weekend.
grantlesueur@gmail.com

Good luck.

(Don Kleinschnitz Jr.) #3

Grant,
I will definitely share the file with you to try it. I can share it on f360 if I had an email.address?
We can share the email by a PM.

(JOHN LAUER) #4

This issues makes me think it’s the TinyG firmware. There were historical arc translation problems on TinyG. I thought those were all solved, but might you have an older firmware?

(Don Kleinschnitz Jr.) #5

I will check the firmware but what puzzles me is that the test cut worked fine (see first picture).

(JOHN LAUER) #6

Hmm. The arc issue I believe is the direction that it entered into or out of the arc. Was it the exact same Gcode? I, too, have found that even on my current firmware, there is very rarely some straight line move that ruins my work piece. I think it happens if I’ve paused the job via ~ and then resumed, but it is frustrating. Although, I may be on old firmware at this point because I haven’t upgraded it in a while.

(Don Kleinschnitz Jr.) #7

It was not the exact gcode as I made some mods and then rebuilt.
I’m trying to go back to that version and look at differences.