Printer pauses for about 1/3 second at corners - leave huge blobs!

I’ve built a Prusa Mendel i2, with a Smoothieboard v1.1 as the controller. I’m using Pronterface for control. As my first print I’m trying to print a 10mm x 10mm x 10mm cube in PLA. Just to check that corners are actually square etc.

Unfortunately It’s failing really badly! At every corner the printer head stops moving for about 1/3 of a second. The filament keeps extruding, resulting in huge amounts of plastic being deposited at the corners. Here’s a video where you can see the pauses, and here’s the print (I stopped it after only a few layers). You can see the huge blobs at the corners.

Has anyone got any idea what would cause this? I don’t even know how to figure out if this is a problem with the way slic3r is generating the gcode, or how smoothieboard is interpreting it. I’d be very grateful for any help!


We need to see:

  • The config file
  • Your firmware version string
  • The Gcode file, and examples of lines it messes up at

Thanks !

1 Like

Hi Arthur. I don’t seem to be able to upload files - the forum won’t let me upload things that aren’t image files.

I may, however, have solved the problem. Someone on reddit suggested running the print from an SD card, and that did indeed run a lot faster. Note that I’m connected to the smoothieboard via ethernet.

Is this a common phenomenon? I would have expected that there’s a delay in sending an instruction over the network, but I assumed that board has an internal instruction buffer to avoid this affecting a print.

Oh yes, running via Ethernet requires special host configuration ( commonly called “ping pong” protocol ), and not all hosts are able to talk to Smoothie over Ethernet correctly/fast. What host are you using? Pronterface? If so you need to follow documentation and set the right settings :

1 Like

You can quote the config and gcode samples inline instead of as attachments. Like this:

the contents of your text file go here

Those marks are single back quote characters (usually to the left of the 1 key on a US keyboard) and you need three of them at the beginning of the line, on a line by their own, to set off a “preformatted” section. Just do that for config file, and separately for the relevant snippet of the gcode file.

1 Like