Opening design causes whisperer to not respond

Hi all,

I have ordered a laser. I wanted to begin checking my files displayed correctly in K40 whisperer. I have a file but when I go to open it in K40 whisperer, it stops responding.

Can you use K40 whisperer to preview designs without a laser connected?

I left the program for a while and the preview area went black.

Found the cause, the file had resized too big and could not be processed.

1 Like

Solved then?

A side note on this topic.
There is a new checkbox, in K40 Wisperer v0.59, for an option called, “Reduced Memory Use”, in the General settings that allows opening larger designs. This option reduces the size of the raster image data imported from Inkscape. The data is imported at a lower resolution 500dpi vs. 1000dpi. I don’t thing the difference would ever be noticeable in anything I do with my laser. The vector engrave and vector cut data is not affected by the setting.

This could be useful in a few different cases:

  1. For a laser larger than a standard k40 and you want to use a large design.
  2. When using an old computer that has a 32 bit operating system so the memory is limited.
  3. Your computer just doesn’t have much RAM (memory)
  4. You just want things to load quicker.

Either way remember that keeping the SVG page size as small as practical for a given design is a good practice and can speed things up dramatically.


A hint for new Inkscape users: Control-A, Shift-Control-R is helpful for reducing page sie. That’s Select All, Resize Page to Selection.


good to know, I always go into the document page setting and set to size to design with a 5mm border.
Now to remember Shift-Ctl-R… hmm that is like the frame and fire command in LightBurn(Shift-Alt-r). I think I can remember that!

1 Like

“Resize Page to Selection” is also accessible in Inkscape from the main screen under the “Edit” menu. Inkscape added it to the “Edit” menu sometime in the last three versions.