Ok so I'm trying to make my own edit of Marlin (got off of

Ok so I’m trying to make my own edit of Marlin (got off of the Printrbot GitHub page), and am running into some issues. Using the Printrbot firmware clone, it gives me a board error:
Error compiling for board [usbtinyisp]Teensylu/Printrboard
So I tried all the other possible boards that I loaded with Teensy, just to see if any worked. None did, so I’m not sure what to do. I know this is not because of something I edited in the Marlin firmware bc even if I load a new copy, and don’t touch anything, I still get the error. Anyone know what is happening? Did I not load the Teensy boards right or something?

EDIT: upon further investigation, all the regular boards that come with the fresh install of the Arduino IDE compile fine, So I guess, like I had thought, the fault lies with the Teensy boards I loaded. Anyone else load Teensy boards, and have success in using them to compile?

Best to fork directly off from the Marlin firmware as Marlin is constantly evolving and changing, and it would be easier to keep your fork updated as those changes go through

@Gary_Tolley_Grogyan Even a direct copy of marlin has this issue, none but the regularly loaded boards work, all the teensy ones i loaded dont work

Back when I did this (sorry for the crap explanation it’s been about two years) you had to use a custom version of IDE that supports it. If you search around for flash Printrboard marlin or something like that there is an excellent blog post someone did along with their own ide. One of the biggest reasons why I never loved the printrboard was because of all the hoops you have to jump through just to get the thing to take new firmware.

@Griffin_Paquette ok, ill give it a better search i suppose, thanks for the point in the right direction

I had issues a long time ago with the USBTiny and uploading firmware. Mainly because the programmer is best used with Atmel Studio to upload firmware, not the arduino IDE.

@Gary_Tolley_Grogyan im only using the arduino ide to compile the hex, the rest is through atmel

Make sure your using new teensyduino software.

@Griffin_Paquette got it, found the forum post you said, and the premaid arduino that has all the boards preloaded. Thanks!!

@Matthew_Del_Rosso not a problem! Glad you found it. Would’ve tried to find it myself but was on my phone.

@Stephanie_A added in rev F a while back. Just make sure that you select that for your board in Marlin.

@Griffin_Paquette ya I saw that, i belive its board 84

Once I edit the marlin code, how do I save it as a hex to be uploaded to the board through ATMEL? Sorry for noob questions, but this is my first time doing this

Just compile it and it will save. You need to look in a certain directory for it. You should see he location a couple lines from the end of the black terminal in the IDE once it compiles.

Have a look here:

Please try Marlin 2.x branch.

I suggest you open an issue on the Market GitHub repo, and I’m 100% sure you’ll get it working, if you don’t manage with the link provided.

Good luck.

@Griffin_Paquette oh ok, thanks! I couldnt seem to see an anwser on the internet, so ur reply was great!