Ok one last question.

Ok one last question. I already posted about this earlier, but I still am having issues with connecting to the Ares. I have it connected to my desktop with an Ethernet cable. When I go into file explorer then to network I can see octopi sometimes/rarely. When I do occasionally see it I can now print awesome things until I shut off ares and turn it on the next time. Then it just seems like the machine just isn’t there. I usually will put in the ip address were it will return with “the site cant be reached” If I plug it directly into the router I can immediately connect. Im running windows 10.Also I can plug/unplug ares and file explorer will refresh, but still not show anything. I did a network diagnostic and it says that it can communicate with name resolution but cant find host name. I am extremely grateful for any thoughts on this. Mahalo!

Try logging off octopi and shut down the raspberry pi. Try this first… Then post if you are having trouble. I remember this was my procedure. Someine else might be able to give you another idea…

When you say “If I plug it directly into the router,” is that your WiFi router? If you can cable Ares to the router, I assume that you can also connect to the router via WiFi. That would still be the easiest.

Else you can run “arp -a” to discover Ares’ IP address, then use IP address to connect. BTW, have you tried the name octopi.local? Even though sometimes this name won’t work in your browser, oftentimes you can ping the name and it will reveal the IP address.

Another alternative requires a bit more networking knowledge and heavy hand: Use static IPs on both your laptop and Ares. But this will be inflexible if you ever want to connect to a WiFi router.

Michael when you say log off from octopi and shut down rasberry pi do you mean this page? In that case I’m already logged off and usually I cant even get to this. Also when you say shut down rasberry pi do you mean pushing the blue lit button on the front then I have done that too.

Yuanj I can connect it directly into the wifi router, but I was trying to connect to my desktop with the cord instead because the wifi router is in a different room. When I have Ares connected to my desktop I am unable to discover the IP address or use octopi.local most of the time.

I was thinking of getting a WiFi extender with an rj45 port to see if it would make it easier to connect.

I apologize for being such a nuisance its just that I cant figure this out by myself. Also I would like to thank you guys again for being so much help with this. I usually can figure most tech things out fairly easily, but this is just stumping me. Mahalo

missing/deleted image from Google+

To be honest, it has been quite a while since I’ve used my Ares. I will boot it up tonight and verify my shutdown procedures and post my steps. I do remember Ares was difficult to figure out the first time, but when you have it dialed in…it just works well. We’ll get you connected properly.

Thank you so much. I dont know how many times i can tell you guys that you are awesome, but your awesome.Thanks

Its all good. I want to see you get your Ares running properly. I have 2 Craftbos that I use right now. But, the Ares is a good printer.

@Warriorie In direct cable connection, I assume that you follow Connect to Ares (OctoPi) by Cable - Google Docs to set up DHCP on your desktop? Another person just reconfirmed that the method works. octopi.local may not work every time but arp -a should always work if DHCP is working properly. Let me know if you get any error.

Well, I started Ares and was prompted to do an update after logging in to Octopi. I did and now I’m getting a 503 error. Looks like I’m going to need to install the latest version of Octopi.

Not sure I will be too much help right now. Maybe Yuan Liu can explore this further until I get mine up and running again. Sorry :frowning:

No need to be sorry. I would have been totally lost without you guys. Anyways here is a screen shot showing that the dhcp is enabled at least from what I can tell. I inputted the arp -a into the command prompt and still don’t see the ip address for ares. I still don’t understand why I am able to connect to it sometimes , but the rest of the time it just is not there.
missing/deleted image from Google+

I realise that I was using Windows 8 at the time. (Windows 7 is quite similar.) Are you using Windows 10? When I open Win10 today, I couldn’t figure out how to set up network sharing to Ethernet, so I cannot tell whether your screenshot is the right one. (I cannot get to the screen you show. Don’t often use Windows myself.) One thing I do notice is that you are using IPv6 only. I haven’t tested v6 with Ares. Maybe you can enable IPv4 on Ethernet?

For now I’m just going to keep it next to the router. I just ordered a wifi extender and im going to see if that allows me to make this all easier. Thanks again for the help.

I looked back into Windows and saw your screenshot. But I cannot get mine to “share” WiFi connection with Ethernet, either. It seems that Win10 is much more involved than Mac. I’ll look around, update the guide if I find a solution.

After quite some experimentation, I am able to serve DHCP on Ethernet in Windows 10. It really gets messy in 10 so it will take a while for me to update the guide. But since you are quick in technical solutions, I’ll give you some quick hints.

  1. Your screenshot shows that your Windows Ethernet is set up as DHCP client. You must set it up as DHCP server.
  2. The method to do this is to select a different interface, e.g., WiFi, to “share” Internet, as shown in my original guide.
  3. In Win10, that is not enough, unfortunately. You must explicitly tell the “share” which services to share. Of course, the only one Ares cares about is DHCP server. (Not sure why DHCP client is even listed as a service! But do not select that one.)
  4. Not only must you explicitly select DHCP server for sharing, but you must also Edit in order to specify which interface you want to share this service to.
  5. In order to specify Ethernet as the the destination for this service, you must not use DHCP in Ethernet configuration; instead, you must specify a static address for Ethernet. Make sure the address is on a different subnet from that on WiFi.

If the address you specify in WiFi sharing for DHCP server matches the static address of your Ethernet card, Windows will assign a new address to Ethernet, and start offering DHCP service to any device connected to it. (Unfortunately, G+ comments only allows me to attach one screenshot.) You should be able to ping octopi (or octopi.local) at that time. (You may need to restart Ares.) If not, arp -a should reveal its IP address.


I’ve finally got it up and running. Just in time to print off some Christmas gifts. I’m probably sounding like a broken record, but thank you so much.