No animation in Chilipepper! Hello all,

No animation in Chilipepper!
Hello all,
I finally waded through the JSON issue I was having, thanks John and Peter! However, tools animation is failing in both simulation and during job run. Since Chrome webGL is not working, I’m using Safari, OSX 10.12.4, Chilipepper GRBL. When I simulate a job, the cone moves to start position and then disappears. If I increase speed, it shows up in flashes here and again. I tried slowing down frame rate all the way to 5fps, but that doesn’t work.
I also tried on Firefox latest version and it does the exact same thing.
Any thoughts?

Tyler

Beautiful pink cone simply disappears. Anyone?
missing/deleted image from Google+

And if I click Toolhead toggle button, the video camera icon, the image disappears entirely. Maybe not enough horsepower? Or crappy Intel HD 3000 vid card built into my Macbook Pro early 2011?
missing/deleted image from Google+

If I refresh the browser page, the work shows up and the cone for a moment, but then disappears almost right away.

From what I’ve been reading, the graphics card in my macbook simply doesn’t like webGL. I think that’s the issue. Too bad…