New k40 playing up

g’day guys,

Got a new laser a few days ago.

Was working perfectly with inkscape and whisperer (im a total novice).
Did some simple designs at low power …nothing over 30 %.
Machine was moving free and everything was good as gold. I was so happy.
It must have been in operation not more than five mins.

Then the head started to move strangely.
Tried three different usb cables.
Now there’s a big lag of three seconds between a whisperer command (dragging the cutter position with the mouse or pressing a jog step button). The whisperer jog step button “stays down” aswell.

Whisperer will receive a file and the cutting head will take a few seconds to move. Then move into place…then cut a mm…then move away…then after twenty seconds…move in again and cut a mm or less…then move away and keep doing that. It takes 15 minutes to cut a cm long vector.

If i press the home key…it moves instantly back to home though? Every other command has a massive lag.

It would take many hours to cut out a simple 5cm square.

Whisperer also has “not responding” during these lags at top of screen.

I’ve reinstalled drivers, tried meerkat, wiped the computer, new usb cables, different usb ports (usb1 and 2 and 3).
Ive tried different versions of whisperer aswell.

My laser tube is perfect…shoots a straight powerful line, the machine cuts nicely. Temps are fine, using distilled water. (distilled water sorted all laser arcing at cathode end)

I had to do stuff like beef up the ventilation and water pump as usual.

Ive got nothing…run out of ideas.

I love this machine and its perfect for what i need.

Has the nano board spazzed out?


G’morning (here),
My short answer is ‘Maybe.’. Whisperer seems to be waiting for the ‘I’m done with last command, there is room in my RX buffer, please send me another command’ signal from the Nano.
Nano may be doing that in a loop until it gets the next command - and then the ‘flaky UART-USB chip’ suddenly works long enough to get another few milliseconds of commands.
I see you did all the right things w.r.t USB cables/ports, so next thing I would do is drop the BAUD rate - and if it still fails but seems to be failing differently, you know it’s a ‘COM’ thing. Good luck!

1 Like

If it were starved for instructions, it would just stop then continue when the instructions resumed. It would not move or ‘move away’ then ‘move again’ it has to be told to do that.

Before doing anything, backup any configuration information you can.

Double check whatever you changed, as it’s usually something like this, however stuff fails.

I would try another gcode sender, if possible to ensure it’s not soft/hardware on the PC.

As a last resort you can flash the controller.

Make sure you backup your configuration before you touch anything.

Good luck…


hey everyone.

Thanks heaps for your helps and answers.

I managed to get a new k40 (second hand still wrapped in plastic) that a dude took the laser tube out of …and it was sitting in his garage.
I’ve taken the nano controller out and chucked it into my machine and she works fine now.
Thank god. …was freakin driving me nuts.
Is there anything i did to bugger up the first nano board?
Or is it just bad luck that she died after a few minutes use?

its put the willies up me that it could be so finicky…time to upgrade?

Hard to say, even though it is working I would:

  • Check the 5V
  • Check the grounds
  • Check all the connections to the Nano and to the motors.

Don’t be surprised is this is just the “Terminator Effect”.


1 Like

possible ground loop issue where the AC outlet you plugged your K40 into is different than the AC outlet your controlling computer is plugged into and bad grounding on either side causes a much higher current flow through the USB cable which ties the grounds together. Using the same AC power leg for both the laser and the computer can eliminate some concern but better to measure and verify the problem doesn’t exist.

Here’s s document which explains different issues ground loops can cause. Breaking Ground Loops with Functional Isolation to Reduce Data Transmission Errors | Analog Devices