New ESP32 workspace launched. http://chilipeppr.com/esp32 I love the new ESP32 boards! Game changer.

New ESP32 workspace launched. http://chilipeppr.com/esp32 I love the new ESP32 boards! Game changer. The workspace has an extra goodie for uploading XBM images to OLED displays as easy as cut/pasting into the widget as seen in the screenshot below.

So cool you updated this for the esp32. Going to give it a try. I just got one going on the esp-ide but that is a pain. Thank you.

I find Lua to be pure pleasure than using the Arduino approach because Lua has you do more of a filesystem approach since all these ESP32’s have 4MB of flash.

Your UI makes LUA a pleasure but yes, the file system is just so cool. The Arduino stuff is OK and the libs for things like the BME280, OLED. LEDs and other stuff makes it easy to do a lot of simple stuff. I just like the LUA file approach and the way it all works with your UI. So far it’s the most enjoyable way to play with any of these boards I’ve played with. I liked the esp8266 BIN building web site and the Windows flash utility too but I don’t see them for the esp32. I read about your chilippr BIN using the http://esptool.py to flash it but have not done it yet.

Yeah, it was VERY hard for me to get the firmware built on my own, but now that ESP32 has so much RAM you can just use my kitchen sink build and not worry about that bin building website as much.

Flashed your bin files with the esptool and brought it up in Chilippr, ran heap, chip id, filesystem, AP access… all worked except blink but I did not look at why. Using a Sparkfun esp32. Very cool to be back in this environment with the much nicer esp32. Thank you John.

Yeah, just pin 5 not pin 2 for this board’s blue led to blink. Works now. First image I tried to copy for XBM hung and after 3 waits I killed it. I have an OLED and BME280 running using the Arduino stuff and even made my own graphics using some conversion stuff from Adafruit instructions to convert to arrays you put in the code itself. Not sure what is an esp32 and what is esp8266 at this point. There is so much to this chip so I hope the LUA stuff keeps up. I’d like to be able to get the Bluetooth config of the AP working so a cell phone can be used to configure the WiFi. Without that it’s not going to work for something like my remote guitar case humidity monitor.

missing/deleted image from Google+

When you say hangs, do you mean the uploading/running of the script to the ESP32? Or do you mean the importing of the image when you hit paste?

Paste…

Which browser are you using? Do you at least see the initial image show up, but just not the monochrome one? Is there an error in the Javascript console at some point? It’s a new feature so curious the bugs.

Chrome, no image, did not check console. I will do more later when I have more time. Sample OLED project would help.