Need some help. looks like I connect when I am on the grbl work

Need some help. looks like I connect when I am on the grbl work space but when I move to jpadie work space nothing comes across on my serial port console but I am connected to my serial port. I am running 1.1 on an xcarve. I was running yesterday with no issues.

I’m actively working on the workspace development at the moment. Are you getting errors in the js console?

Try also toggling verbose mode and removing the filter. However in any event it does look as though you are not getting any transit through sjps. An idea is to stop/start the server and refresh the browser.

Also note that the current version of sjps is 1.94.

looks like i have version 1.88 so I will update that and give it a shot.

no luck with verbose mode and removing the filter. As far as sjps 1.94 I can only find 1.88 and that is what i have been running. Any other ideas?

Not a lot to do without debugging feedback. We would need all info from sjps and all info from the js console (ensure you turn it on from within CP).

missing/deleted image from Google+

nothing at all comes across serial port console.

ussually this comes across. But nothing today.

Grbl 1.1f [’$’ for help]

You’re not running sjps in verbose mode.

With CP the serial comms are muted. To unmute them you need to remove the filter from the serial port widget and turn on verbose mode from within the grbl widget.

But sjps verbose mode is more useful.

I think i got it. Sorry I have only been using cp for a week.
missing/deleted image from Google+

but still am offline

Ok.

So what is the js console saying?

Just so we are on the same page you are talking about this?
missing/deleted image from Google+

No. The JavaScript (js) console.

how about this
missing/deleted image from Google+

In the grbl widget there is a drop down menu. Try selecting force v1 mode.

done, still nothing
missing/deleted image from Google+

After I did that i disconnected and reconnected and nothing

Ok. It’s 1:30 in my timezone. I will take a look in the morning although your issue is not manifesting on my setup. The console information will help.

In the meantime feel free to fork the widget and apply a fix yourself;. You should look at the isv1() method. I’m happy to accept a pull request if you want to recontribute the fix to the other users of my workspace.