Need help with a spindle problem

(Dwight Casteel) #1

I bought my R7 last November to replace my near 5 year old Piranha, got it (sort of) running in December, running for simple things in January - - and Hobby-Fab went away in February. Nevertheless, by this month I had conquered the R7 and had started using it in my woodworking business.

Then today I start a job, hear the spindle start and turn away just in time to hear the $40 bit snap. Seems the spindle started, but the shaft did not. It just pushed the static bit into the wood and tried to feed it until it broke.

A number of tries later I had succeeded only in heating the spindle but not in getting any movement.

The water pump is working fine with a good flow through the spindle. The shaft moves freely when the spindle is off so did not freeze, but is very rough when turned by hand with the spindle running.

My simple mind says it is either a gcode problem, a controller problem, a wiring problem or a spindle problem. The gcode comes from Vcarve Desktop with the grbl post-processor and has never been a problem before. Since the spindle sounded as if it was running, and it did heat up, I want to rule out any controller or wiring problems. If I am right (big IF), that leaves just the spindle.

So I am looking for someone who has taken one of these things apart. Is it likely that the problem will be repairable? Or do I just shrug it off and order a new one? Don’t want to do that but since I am in the middle of projects that require a CNC, and a CNC bigger than the Piranha, I do not want to waste a lot of time trying something that is a lost cause.

Any suggestions out there?

(Anthony Bolgar) #2

You can eliminate Gcode issues by running a known good program that ran before. If you have the issue still, then it is not the Gcode. Wiring issues are very unlikely unless you made any changes to the wiring. You can look for any obvious wire breaks, melted insulation, or broken connector pins. If that all checks out then it sounds like the spindle is the most likely suspect.

(Dwight Casteel) #3

I should add that I have watched the YouTube video (https://youtu.be/6J20Cqf6VHk ) on repairing a spindle very similar to mine and find it intimidating. My woodworking shop is not equipped the way that shop was.

(Anthony Bolgar) #4

In that case, if you eliminate everything other than the spindle, your best bet course of action would be to buy a replacement spindle. You could always sell the old spindle for parts to someone.

(Don Kleinschnitz Jr.) #5

What kind of spindle?
What spindle driver?
Can you connect the spindle directly to power on the bench to test it?

(Michael K Johnson) #6

R7 is typically an 800W 65mm water-cooled AC spindle.

(Dwight Casteel) #7

Spindle brand is unknown but is 800 W, 65 X 195 mm, 110v. It is the one that came with the R7 kit from Hobby-Fab.

(Michael K Johnson) #8

I don’t have an R7, but I think that this is an example of the type of spindle and would probably work with the same VFD. (My recollection from reading the Hobby-Fab site was that it was a three-phase and shipped with a VFD.)

(This is not an endorsement of this particular unit or vendor, just a link for disambiguation.)

(Don Kleinschnitz Jr.) #9

Can you elaborate on what you mean by these statements?

“Seems the spindle started, but the shaft did not.”
What do you mean by “spindle started”.
The motor internals are spinning but the shaft is not turning?

The shaft moves freely when the spindle is off so did not freeze, “but is very rough when turned by hand with the spindle running.”
What do you mean by “spindle running”?
The spindle internals are spinning but the shaft is not?

Is this your VFD?
https://amzn.to/30axDDx
I think that is a HY01D511B (maybe)

Assuming the control to the VFD has not changed and good, the spindle and/or the VFD could be bad.

You could disconnect the controller and start the motor from the VFD panel and measure the voltage on the motor.

(Dwight Casteel) #10

You are correct, when power is applied the motor is turning (at least sounds as if it is) but the shaft is not. If I try to turn the shaft by hand there is some “jerky” resistance. If the power is off I can turn it freely by hand.

That VFD is similar to mine but not identical.

I tried Anthony’s suggestion of running gcode that had run successfully before but the problem was still there so probably not something spurious in the gcode.

The problem occurred between two runs separated only by a tool change. The first run went as planned, the second run was the bit breaker mentioned earlier.

Yesterday I bit the bullet and ordered a replacement from Amazon. It is supposed to be here (AZ) by 9 PM today. When it arrives I’ll install it and post the result.

2 Likes
(Dwight Casteel) #11

The new spindle got here about 6PM yesterday evening. It is fully compatible with the original right down to the connector and the pin assignments for wires coming from the inverter so I just installed it and ran a test. It did not spin! I said to myself: “Geezer, you just bought an expensive backup to a spindle that will probably outlast you.”

I started backtracking the wires through the system and found no problem - - until I removed the terminal block on the gantry and the “U” wire fell out. I use crimped ferrules for all the connections to the terminal blocks and apparently the crimp on that particular connection had cut through enough of the braided wire that over time the wire had separated but remained wedged in the ferrule well enough not to fall free until I moved the whole block. My original visual inspection was not good enough, I should have pulled on every wire.

Once I redid this connection everything worked fine for both spindles.

Thank you to all who helped!

Must go now, work is backing up.

3 Likes
(Anthony Bolgar) #12

Well now you have a backup spindle for when it finally does die. Glad you are back up and running. One thought, will Amazon let you return it?

(Dwight Casteel) #13

Although I’m sure they would, I decided to keep it so didn’t ask. I have returned a few items over the years when they were broken or not as advertised and Amazon was quite good about it. But you do need to ask first.

1 Like