Need Help! K 40 axis problem !SOLVED!

Hi, I have a k 40, but I have a problem with the axis, y moves with difficulty while x is not recognized in any way.
I replaced the board, now I use a Mini gerbil but the problem persists. could anyone help me? could it be a hardware problem related to step motors?
In the link below you will find a video that demonstrates the problem.

Thank you all.

1 Like

Normally the first thing to check when an axis doesn’t move at all is the limit switch for that axis. Do you have a multimeter?

“moves with difficulty” is probably mechanical. Does it move equally easily on both axes if the machine is powered off and you move the head by hand?

Your video link doesn’t work, at least for me. If you could repost the video it would be helpful.

Hi Michael, i don t have a Multimeter but i will find one soon!

When the machine is powered off it moves equally easily but when the power is on it moves only y (with difficult) and x is not recognized by the software.

Hi Ned,
try with this link VIDEO

That sound isn’t normal. When the y-axis reaches the back does the y-axis motor keep running?

And is the x-axis motor running at all?

Yes Ned, the y-axis motor keep running.

No, it doesn’t t work.

Ok, for homing the K40 uses optical endstops. The optical sensors are black U-shaped pieces where a metal tab slides into the middle of the U-shape at the limit. I’ve included a pic of my y-axis sensor and tab. Make sure nothing is blocking the sensor and make sure the tab is aligned correctly to slide into the middle of the sensor.

Than you Nedman, I find the solution!!!

Under the optical sensor was a wire that controlled both the end stop and the x axis and was ruined. I replaced it and now it works.

Thank you so much for you help!!!


Glad to help. :grinning: