Need Help Genmitsu PROVerXL 4030

I recently purchased a Genmitsu PROVerXL 4030. It, unfortunately, was delivered in a very damaged box from UPS. After opening the box and inspecting the contents, it appeared that only a few minor items where damaged. A small partial board, a waste rail, and the spoil board had been chipped a bit. Again nothing major.
I have been in contact with Sainsmart and they assured me not to worry, they will send me replacement parts.

Now, the real issue; I proceeded to put the CNC machine together, meticulously following the directions included. Once assembled, I installed Candle on my laptop and proceeded to operate the machine to test the function of the Y, X, and Z Axis. This is when I noticed, the two Y axis did not move at the same rate starting out and there seemed to be a bit of a jerking motion from, what is referred to as the Y1 axis, this is also what I would call the right-side.
I have spent 2-3 days now disassembling and reassembling the Y1 and Y2 motor/couplers and nothing has worked. At first I thought, maybe there is debris on the screws that move along the Y axis but I have cleaned it off and re greased both of them. The motor to screw couplers are what I would consider to be very cheap. They are a three piece design with plastic/rubber middles and I am wondering if that may be my issue.

I have to admit, this is my first CNC and I am completely stumped. I have asked Sainsmart to ship a new Y1 side but have not received an email back as to if/when that will happen.

If anyone is interested in helping me, I could gladly record/video the machine in motion so you could get a better idea of what I am referring to, just let me know. Short of that, any help, ideas, thoughts, punches to the head… would be greatly appreciated.

Anthony Waterman

The couplers are “spider couplers” or “lovejoy” couplers and that’s normal. The plastic is a feature not a bug. :relaxed:

It’s possible that one of the Y motors isn’t hooked up right, or that you have a broken motor wire. It’s worth uploading pictures.

For videos, the best thing is to upload the video to a service like youtube and then link to it here.

Chances are pretty good that we can help you here; several folks here have built routers from scratch and have encountered lots of ways to fail. :smiley:

That is great! Thank you for the reply. I will check the wires, and upload a video tomorrow morning. I will try to be a through as I can so as not to leave any unanswered questions.

Thank you!


1 Like

Ok, so here is a video of what is happening. It is a short one and I am more than willing to record more and go over how I have it set up if need be. I see this as just taking baby steps since I am still new to this.

Again, thank you for any help.


Are the two motors connected in parallel to the same driver?
Looks like the right side moves first then the left catches up?

I would try swapping the motor connections and see if the problem reverses. I.E. the opposite side starts moving first.

1 Like

First off, thank you Don for replying.

I did what you said, even went as far as swapping the motors around at one point, but unfortunately it still has the same issue. It is even more noticeable at slower move speeds. If I set it to move at 100mm continuously, one side ( depending on whether is move it forward or backwards ) has a grabbing issue, so bad it sounds a bit like it is grinding.

Pretty close to my level of what I understand about these machines, not really sure what to do other than ship the entire unit back.


Yeah, I know, FacePlant. But there’s a 23K member faceplant group dedicated to 3018s and Sainsmart products including the 4030XL

OK, here’s the obvious: A new machine should not be doing this. I am confident in my ability to diagnose and fix such a problem if the machine were in my hands, and I would probably return/replace in this case. That said, it’s your call and we can continue to help you diagnose the problem.

Also, if you are on facebook and find the answer in that group, do please do say here what it is; one of the points of running this site independently is to make knowledge like that discoverable for the next person.

I see this is a screw-driven machine. “Racking” like this is unusual. The question is whether the problem is mechanical (e.g. something wrong with the construction pushing against the motors) or electrical (e.g. one motor hooked up backwards).

Have you tried removing the motors and commanding movement and seeing whether both motors turn correctly if they aren’t connected to the base?

Also, @donkjr asked an important question:

You’ll want to make a practice here of making sure, for every question asked, either to provide the answer to the question, or say that you don’t know so that we can follow up. It’s OK to know know what we mean; ask clarifying questions. Even those here with extensive knowledge had to start somewhere! :smiling_face:

1 Like

Don and Michael asked very good questions and hopefully you can get back to them and answer their questions. These machine controllers have come with 2 different ways of driving two-motor axis’s like your machine.

One controller might have a single driver with 2 motor connections and it’s configuration for the firmware likewise has just the one config section for the single driver.

Another controller can have a separate driver for each motor and likewise will need/have 2 configuration sections for each driver.

Getting down to what’s causing one side of your machine to lag behind the other will be a process of understanding how the motors are being controlled and then figure out if the problem is in the software, the electrical system or mechanical system.

If you haven’t done already I would recommend you contact SainSmart and prove a link to your video. I already did similar for my 4030 Prover XL when the X axis lead screw showed signs of being bent, They sent me a replacement free of charge. I also had problem with the bolts on the Y axis carriage. After explaining how tight they were and how easy it was to bung up the hex socket in the head. They then sent me a replacement assembly for one side of the Y axis. So do provide them with as much information as you can. They are very good at responding to your request. Do keep in mind the situation in China as it will probably impact any solution to your problem.


Has this issue been resolved? I moved recently and when I set up my 4030 Prover it does exactly the same thing. The Y2 motor will start to move and then the Y1 motor acts like it almost spins backwards and finally gets with the program and will move the gantry but it is VERY noisey and binds up. I measured after moving the gantry using the motor and it was almost half an inch out of square when I stopped it. HELP Please!! Mike

1 Like

Looks like this is old, so hopefully someone has figured this out by now? I’m having the same problem. New machine and I tore it apart and put back together (machine was half put together by the china!). I did figure out if you unplug the power to the box and manually move They move very smoothly no jerking. Plug the power back in to the control box. With it still powered off then it binds when you try to move manually. (Plugged in but off). Give me an answer pleeeease. Thanks

In general when you have two motors driving a gantry in tandem, and one goes the wrong direction, you need to swap one of the pairs in the wires going to one of the motors, or sometimes it’s possible to change a bit in software.

But when the unit arrives this way, who knows what else might be wrong? I’d say if it arrives that way, send it back for a refund.

Make sure that the little plastic coupler that connects the motor to the lead screw is attached properly. Make sure that the small grub screw is lined up with the flat part of the motor shaft then tighten down the larger grub screw and finally tighten down the smaller grub screw.