My Printrbot jr has completely stopped connecting/ working.

3d-faq
3d-qa
3d-help
gplus
(boog nish) #1

My Printrbot jr has completely stopped connecting/ working. I took a break yesterday eve and when I got home, I turned on Repetier and went to connect- nothing- ‘couldn’t open port for device’ message only. So I unhooked, rehooked and tried to connect again. Same message, just as if I didn’t have power or USB plugged in. As I sat trying to deduce what could be going on, I noticed filament starting to ooze from hotend. YEP, was heating up but not being recognized by Repetier . Tried to connect, even using a different USB cord, a couple more times and quit for the night after having no success at connecting-
This morning I have no connection at all, no heat… Explored idea of updating firmware only to be told that no device was present.
Any ideas? Is there any chance that something fried? Or possibility that this is related to the seeming unexainable extrusion issue I was having?!?
When the power cord is plugged in, I CAN see a green light on, within the electronics housing. So there’s some power there? Help!!!

(Andre Courchesne) #2

Happened on my @Printrbot Simple once, ended up reflashing.

Some also suggested that the processor board could boot lock if booted with one of the end-stop switch was engaged.

(boog nish) #3

How would I re flash ? When I went into for firmware updater it wouldn’t even recognize device present*
New to most of this<<

(Tim Sills) #4

Yup, have experienced the same issue where it can’t connect. Reflashing will re-establish connectivity. I was thinking it might’ve also been as a result of the shut down process so now I make sure to always disconnect in RH, remove USB cable from computer, and then power down printer.

Ever since I started shutting down like that I’ve never had this problem again.

(Andre Courchesne) #5

@boog_nish not sure which board the junior has but on my Simple I need to place a jumper on the Printrboard to put it in programming mode.

(boog nish) #6

I have absolutely no idea how to ‘place jumpers’, Ah crud! I bought my bot used, have never had to mess with the electronics- only everything else

(Andre Courchesne) #7

This may help
http://printrbot.com/support/instructions-and-guides/instructions-flashing-the-firmware-on-your-printrboard/

You will need to get your hands ‘dirty’ :slight_smile:

(Nathaniel Stenzel) #8

Good luck with it. I wonder if this is related to your other issues.

(Mark Fletcher) #9

Have you checked your device manager on your comp to see if the driver is still attached to the COM port? May explain the issue with it not being recognised?

(boog nish) #10

+Nathaniel Stenzel, I wonder the same thing*
+Andre Courchesne thanks for link- that’s what I’ll be doing this evening!
@Mark_Fletcher , lost me there, I’m on a Mac. I will figure out how to check that
Thanks to all, cuz this is awful!!!

(boog nish) #11

@Andre_Courchesne1 thanks for that link- within it, it directs to go to Amtel FLIP, I am on a Macbook pro. other option? Can I just do the first part? the bridge and reset? or will this leave my board ‘blank’?!?

(Andre Courchesne) #12

@boog_nish On OSX here also. Here is the guide I actually used: http://help.printrbot.com/Guide/How+to+Reflash+Firmware/78
Was on my iphone a bit earlier and was not finding it.
At step 5 it ask you to skip to step 11 for OSX.

(boog nish) #13

K ThaNk You
kinda nervous but i will be sitting down to work on it in a couple of hours from now

(Brook Drumm) #14

Contact support for replacement. Not sure what happened but we can replace!

(boog nish) #15

+Brook Drumm. This is an older jr that I bought used via eBay. Is there still anyway you would be able to help then, if after I try flashing it is still ‘comatose’?
This is my first bot, by the way, and it’s been awesome, did some upgrades and have been printing all sorts of things well for a while now, until this. Needless to say, any help, support or suggestions are GreatlY appreciated. New metal simple kit is on my list**

(Brook Drumm) #16

I could sell you a working refurb board for $50 to cover my cost. ??

(John Davis) #17

@Andre_Courchesne1 If the board does “boot lock”, is there any way to recover? (Short of j-tag that is. )

(boog nish) #18

@Brook_Drumm Right on, man. I appreciate that. If once i dedicate some time to trying to reflash etc, and still am stuck, I may contact you. Though I’ll be thrilled if i can fix the issue .
then i can justify ordering my simple metal, kinda,lol. Also, just wanna say i think that it’s great that you keep up so much as to take notice of a small time enthusiast such as myself. have watched yours/Printrbots progression since i started following the whole reprap thing, there was a reason i chose your bots as my 1st. So, thanks

(Ed Baker (E Baker)) #19

@boog_nish take a look at the wiki on reflashing the printrboard at http://www.printrbottalk.com lots of helpful people to help you through it as well. I agree, need to reflash.

(boog nish) #20

K
Ill almost certainly have a question or two when I go at it lol