Moving to Lightburn on the K40

That’s the one that I used. Still not working even after trying to set it up as Ethernet/TCP using 127.0.01 IP

I’m on v1.3.01 of Lightburn, maybe it’s a too old version? :thinking:

@Tatarize is there a best place for this question? This wasn’t originally about Meerk40t so it wasn’t posted in Meerk40t — but also I don’t know whether there’s documentation of some sort that you could point to beyond what is already in this thread?

so he did the same thing he did so that Lightburn DSP could work with the M2 Nano? ie Lightburn G-Code can drive the M2 Nano through a Meerk40t translation server. That’s great.

1 Like

wow, that’s a very nice capability. Now to figure out why @Alb673 can’t get connected.

1 Like

I’ve messaged on Github, as well, as the only version I can see is the 0.9.4020, and it seems that I would need the 0.9.5beta2, which I can’t see from were to get.
Let’s see what they say :crossed_fingers:

should be found here - Releases · meerk40t/meerk40t · GitHub

I just found another post of a beta release made a few year ago and then checked the URL and clicked release instead of the particular tag of the old beta. Anyway, there you go.

Expand the “assets” section to see your downloadable files.

Thanks for the link dougl
Just downloaded it, made executable, started it, and for some reason it opens showing the older version 0.9.4042…

check your OS process listing to see that it’s really running the new/beta version. That’s the sure way to know it’s the correct executable even if the version is showing incorrect.

You were right…
System process shows new version, software window, the old one, Meerk40t console seems to be connected, but Lightroom it isn’t :thinking:
Machine is running, and USB cable it’s working.

Is there anything else I should do in Lightburn to connect it?
Thanks

I would go with what version of Lightburn the developer mentions or is likely to have developed against. Especially since v1.3.x of Lightburn is from 2022 and they are now on version 1.6.x

Yeah. Might be worth getting an upgrade, if not only for using with Win tablet, since Linux Mint is not supported

just because Mint isn’t listed as a supported version doesn’t mean it won’t work on it.
Linux Mint 21 is based on Ubuntu 22.04 which is listed as a supported version.

It’s easy to test by downloading the ISO file, making a bootable USB drive using something like Etcher then boot your computer off the USB drive, download the Lightburn-Linux64-…7z, unzip it( 7z x ./Lightburn-Linux64-…7z ) and run it.

There is also an appimage version of Lightburn which might only require installing the fuse filesystem library(or not) to run after making the downloaded file executable.

1 Like

I was told on Lightburn forum, that Mint is not “officially” supported.

To be honest Mint worked for about 2 years, then one day the window maximise button was gone, and to get it back had to remove all Lightburn windows, and then reopen them. Probably a Linux update messed that up.

I just tried on my Win tablet. Meerk40t kind of work with Lightburn. I have found that 35% in Lightburn is not a 35% on the machine, so I will have to do some testing checking the Amp meter

I certainly can try the live Linux approach, and test it. Would be interesting

So here’s what I do since I also have docker on my machines and one of them is older(Kubuntu 18.04.6) and no longer supports the latest release. And to launch a 2nd application, like Meerk40t in the same docker container, it would be a modification of the last command which launches Lightburn but with Meerk40t application specified.

I create a docker file which describes the system I want and adds the features I need to run a particular application. For Linux Mint 22 it looks like this in file named linuxmint_docker.file :

FROM linuxmintd/mint22-amd64
RUN apt update
RUN apt install -y libusb-1.0-0
RUN apt install -y libpulse-dev
RUN apt install -y libgl1
RUN apt install -y libxkbcommon-x11-0
RUN apt install -y libxcb-image0
RUN apt install -y libxcb-keysyms1
RUN apt clean
RUN apt install -y libxcb-render-util0
RUN apt install -y libxcb-icccm4
RUN apt install -y libxi6
RUN apt clean
RUN apt install -y libxrender1
RUN apt install -y net-tools
RUN apt install -y iputils-ping
RUN apt install -y libgtk-3-0 fuse locales
RUN apt install -y libqt5gui5
RUN apt clean

# Set the locale
RUN sed -i '/en_US.UTF-8/s/^# //g' /etc/locale.gen && \
    locale-gen
ENV LANG en_US.UTF-8  
ENV LANGUAGE en_US:en  
ENV LC_ALL en_US.UTF-8     

RUN echo “lbuser:x:1000:1000:LightBurn User,:/home/lbuser:/bin/bash” > /etc/passwd
RUN echo “lbuser:x:1000:” > /etc/group

ENV DISPLAY=:0

Then to create the docker container I use this command:

docker build -t mint_lbr -f linuxmint_docker.file .

Last, since I extracted LightBurn into my home directory(using 7z x ) the command to load Lightburn in the LinuxMint 22 docker container goes like this:

docker container run --device /dev/video0:/dev/video0 -u 1000:1000 -v /home:/home -v /tmp:/tmp -h Light --mac-address 02:42:ac:11:00:02 -it mint_lbr /home/lbuser/LightBurn/LightBurn

Here’s LightBurn v1.6.01 running and xeglgears also running in the same container.

2 Likes

If you want to use the camera in the docker container then add this line to your docker file:

RUN apt install -y libgstreamer1.0-0 libgstreamer1.0-dev gstreamer1.0-libav gstreamer1.0-tools gstreamer1.0-x gstreamer1.0-plugins-base-apps libgstreamer-plugins-base1.0-dev gstreamer1.0-plugins-bad

and you’ll want to add “–group-add 44” to your run command so that your user is part of the video group like this:

docker container run --device /dev/video0:/dev/video0 -u 1000:1000 --group-add 44 -v /home:/home -v /tmp:/tmp -h Light --mac-address 02:42:ac:11:00:02 -it mint_lbr /home/lbuser/LightBurn/LightBurn

I verified this on both Ubuntu and Linux Mint docker containers.

2 Likes

Haha… I’m not that advance with Linux. Had to Google what docker is.

As soon as it get some time, I’ll give it a go. Maybe try the live option that you mentioned first

Thanks for the help so far :+1:

Alberto

1 Like

Just found that there’s a switch for appimage which extracts and runs in place( --appimage-extrace-and-run ) and it worked!

docker container run --device /dev/video0:/dev/video0 -u 1000:1000 --group-add 44 -v /home:/home -v /tmp:/tmp -h Light --mac-address 02:42:ac:11:00:02 -it mint_lbr /home/lbuser/Downloads/LightBurn-Linux64-v1.7.00.appimage --appimage-extract-and-run

I had been running appimages from an extracted directory structure because I didn’t want to deal with loading the fuse filesystem driver.

1 Like


I just had another go, and sadly the live option do not seems to work for me, or maybe i missed something…

I’ve run Mint 21.3 from USB, done some updates, run Lightburn 1.6 appimageband Meerk40t appimage.

First i created a machine manually in Lightburn as grbl-lpc
Meerk40t doesn’t seems to connect to the machine while in live session.

Tried to connect the cable directly to the laptop but still same issue.

I need to try make some stands for a market, so at the moment I would either design in Lightburn and export as SVG or get a better grasp of Meerk40t.

Than when i can get my head around it i will check the docker option.

Damn i like Linux, but its so frustrating that sometimes i get stuck on doing simple things, like burning a USB that somehow has gone “read only”…

Again thanks for your effort :+1:

There’s no reason to even load LightBurn if you can’t get Meerk40t to connect over USB to your machine. You are able to use Meerk40t to control the machine over USB though? If so it really sounds like a Meerk40t configuration issue.

Again, don’t even both messing with LightBurn if you can’t get the Meerk40t controller to make the USB connection. Gotta fix that before doing anything else. I had thought you had the grbl controller running but it looks like you don’t.