MKS SGen can't connect to motherboard with GRBL-LPC

Hello. The problem is that I cant connect to MKS SGen (as SBase but with difference that I can choose drivers)

What I do:

  1. I copy mks_sbase_p1_23_firmware.bin to flashcard (128Mb Fat file system)
  2. I rename it to firmware.bin (low register), then I pull the card out of the laptop and insert it into the board
  3. I connect USB cable to MKS Sgen
  4. D7 is constantly on, then I see D1 light up, D2 light up and D1 light down, then D2 light down and D1 light up constantly with D7.
  5. Windows 10 (x64) at this time tells me that it cannot recognize the device
  6. Then I disconnect USB cable from laptop and connect it back
  7. D7 and D1 light up, then D1 light down. No messages from Windows 10. Looks all good.
  8. Then I open LW4, and trying to connect to com3 (the device was determined in the system)
  9. But: image
    no blinking from D1,2,…,6. D7 light up, and thats all.

pmth from github has same problem.

I tried to create an unnamed file with the env extension. And write there settings for restart. Did not help.

Did you try normal smoothieware on that board? Does it work?
Did you try to connect with a different software (like Arduino terminal)?

The Sgen has a slightly different MCU (LPC1769) than the SBase (LPC1768). I don’t know if that could cause this problem.

1 Like

Hello, cprezzi. Thank you for visiting my topic.

Sure, I checked the performance on the original firmware (proposed by the seller). By default, the board comes with a very old firmware. This can be seen on config - used old params.

But I managed to install the latest firmware. So the board workable with smoothieware.
With smoothieware all terminals that I have works well: octoprint, laserweb4. By the way, everything works good on win7x64 and win10x64.

Is it normal that the drivers that come with the smoothieware do not fit grbl-lpc? When I write the grbl-lpc firmware to SD Card after reboot the board is no longer defined as a standard smoothieware-board.
I have to add drivers from this folder VCOM_lib

When grbl-lpc is installed on the board, I tried some more programs: grbl controller and universal g-code sender. Nothing happens when I try to connect to the board.

Does grbl-lpc check the end-sensor connectivity? This morning I had an idea: is it necessary to connect end sensors… I understand that it is necessary for work. But is it necessary for a simple launch of the board and getting the settings by $$ command?

So, I will try to connect my board via Arduino IDE. But I think that nothing will change.
Maybe I should try to use the COM Port listener like this?

P.s. I still have SKR v1.3 with LPC 1768. But in this topic, you said that there was something wrong with the layout.

Correct, grbl_LPC doesn’t use the same drivers as Smoothieware. It uses USBserial drivers that are usually preinstalled on Windows (I think also on OSX and Linux). If not preinstalled, you need to install the VCOM drivers. This driver is emulating a serial COM port.

If you cannot connect with a simple terminal program, then I guess the firmware has crashed and doesn’t work on that board. The terminal connection is not related to any sensors connected.

The SBase board has a I2C Chip to set the stepper current. The SBase firmware will crash, if the SGen doesn’t have this chip.

The SKR v1.3 is not compatible with grbl-LPC, because the stepper pins are spread over multiple ports.

1 Like

Can I somehow check whether this I2C chip is there or not?
Am I right? An indirect proof of its this board support TMC2208 drivers via UART.
The seller provided me this board with these drivers.

If your board has jumpers to set stepper current, it probably will not have a I2C chip.
Grbl-LPC doesn’t support TMC2130 nor TCM2208 yet.

1 Like

I moved this topic the the Controllers/Grbl-LPC category, where it belongs to.

Hmm… I looked at the board. Near each driver-block, I see only three jumpers.
I suppose that this jumpers setup 1/8 1/16 1/32 from step. As I know usually they are called M1 M2 M3.

Can I check indirectly: I will set the resistor on the driver to the minimum, and set the current to 2A in the smoothieware configuration file as alpha_current 2/betta_current 2 and so on. Then I will jog the axes. If the axes can be easily stopped by hand, the board is not controlled from the configuration file. And the board does not have this chip. Will this conclusion be correct?

Even just in the usual step / dir mode? Or do you mean that it is still impossible to control the current on these drivers?

I guess this board has no I2C stepper current chip, because it’s not needed if you have current pots on the driver.

By not supported I mean grbl-LPC has not SPI or UART control option.

1 Like