MKS DLC32 Boot Loop problem

I am upgrading a Full Spectrum Laser with the MKS DLC32 controller and TS35-R display. I had everything working pretty well, but decided to update the firmware on the controller (the old version has a bug in the y axis direction control). I used the MKS LaserTool v2.04 software to flash the latest firmware (version 2.3) and it was successful and everything seemed to be working perfectly. I then turned the system off for a few hours, and when I came back it no longer boots up, but instead gets stuck in a boot loop. The logo shows, then it goes to the home screen for half a second, then the screen goes blank and the process repeats. Does anyone have any ideas how to fix this. I can no longer access the controller with the LaserTool software as the computer does not see the DLC32 anymore. Is there any way to communicate with the ESP32 chip without a successful boot?
Here is a video showing the behaviour:


Does it change if you don’t plug in the display?

Yeah, like Michael said, if that still doesn’t work, unplug all of the motor drivers and the 12v power cord. The board should still boot powered from the USB for flashing, if I remember correctly. I have a couple of these boards and I know they have had some real ups and downs with the firmware since they released them. You can also check out their GitHub issue tracker and see if anyone else has had the same issue.

1 Like

Thanks Michael and Tim! I tried unplugging the display and was able to connect to the board and reflash it. It is now working again! (Though homing is not working with the new firmware…).

1 Like