MKS DLC v2.0 controllers not working consistently

Has anyone got one of these to work? I have 3 and have tried everything I know to try and will show that it takes GRBL and 5 minutes later it won’t recognize the board.

Just to be clear: Are you asking about the entire all-in-one controller as in the description, or the MakerBase MKS DLC v2.0 board for which firmware is included in the top post?

If you mean the MKS DLC v2.0 board, it’s been running my OX for months now.

If you mean the all-in-one controller, @Dwight is successfully running his R7 on one:

It’s the board. I purchased a black box from Brandon and it’s been great up until last week. I went to boot the machine and UGS would not move the machine. I have tried to reflash with the firmware posted here with no luck. I also bought another MKS DLC v 2.O, flashed to arduino uno 1.1 and it worked for about an hour and now it will not boot. Windows shows it as USB-Serial CH340 comm 3. When I try to load Arduino I get a time out and no response from board.

The box gave me great service for over a year and Brandon is a great guy and help me alot when I was getting started.

Just trying to get the black box back going. Thanks for any help you can offer.

Sounds like something is killing the boards, then. Sounds super frustrating. I would definitely start measuring all voltages. Might consider running simple job with no sensors connected in case you have something like broken insulation occasionally faulting spindle supply voltage to a sensor pin. Also make sure everything is properly grounded.

Thanks for the response Michael and all good points. I’m thinking it has something to do with the windows drivers. They will recognize the Arduino boards (chips) but will not recognize the MKS chips. The drivers that were posted did not want to load. I believe if we had good drivers the boards would respond.

Can you check your computer and see which driver you are using and what windows calls your board? I’m using windows 10 and I believe this happened after I did a windows upgrade.

I’m going to migrate to the real Arduino Uno board with external drivers for now but would like to get the box going for a spare as I have 2 boards in hand and another ordered for a spare (ordered it before the problem with the new board).

Thanks again.

I use only Linux, so I won’t be much use to you here, I’m afraid.

The windows driver model is something I cringe to hear discussed in polite company. :roll_eyes::stuck_out_tongue_winking_eye:

Thanks again. Let me know if you hear anything.

Well after three days of pulling my hair out I finally have it fixed. It wasn’t the board it was a bad usb cable. Nothing like looking for the obvious first…

Thanks

Glad you found the problem in the end! I’ve moved this to a separate topic to make it clearer.

Thanks Michael. Actually I had 2 problems, one was the bad cable the other was actually a bad board. I finally got the replacement to program last night and will be trying it on the machine hopefully today. The 66 library loaded and it will connect to UGS so hoping for the best.