Mini Kossel Delta - Alpha & Beta motors move at same time

I bought a 5xC board to replace the RAMPs that came on my MakerGeeks Mini Kossel kit. I am using the standard delta config file from Github, as described in the Delta FAQ page.

The only change I have made is to reduce the alpha_current setting to 0.4 as the default values was getting it too hot; I did the same for the B & C current settings. I have tried values of 0,6 and 0.8,which warm the motors up after a while, but they are still weak. . I have tried different combinations of the 3 stepper motors (with & without belts) and I get the same result. I am using Windows 10 & the latest version of Pronterface. All the lights are good, with both orange lights on and the middle 2 green ones flickering away. I have checked the pins on the motor and they seem OK, as each motor moves up and down… just not consistently. Should the motors be getting as hot as they are even when not running ? i.e am I just running too little current?

The A & B motors run at the same time. They are weak and inconsistent, so they start out OK but after moving a few inches the pitch of the motor changes and sometimes it just stops. Sometimes they go in the same direction, sometimes in opposite. I have not got it to home yet as the motors controller does not work properly. In Debug the corodinate values adjust OK, including going negative, but the motor control is very poor, often stopping completely after it has moved a few inches. It was like this out of the box, which is disappointing to be honest. I have read all the Instructions and troubleshooting pages I can, but seem to be stuck now so any help would be useful.

Imported from wikidot


Warm motors ( even hot motors ) are normal, and 0.4A is very likely not the right value. You need to find the rated current value for your stepper motors ( from the seller or the datasheet ), and set the current to that value, no matter what gets hot.

Motors moving at the same time can be normal on a delta … that’s kind of the principle of a linear delta, so not sure what the problem is.


I have connected up the Z axis motor and it is moving along with all the others…! So when I press X to move up 10 units all 3 steppers start turning, which is very strange. I can’t get more than about 6 inches of motion out of it before it just grinds to a halt and often then goes back the way it came. I have put Pronterface on my Macbook and get the same results; also tried different USB cables. The endstops function correctly so at least something works….

If I have blown/broken the board then how can I tell?

I bumped up the current to 1.3A, tightened up the belts and it is a lot better. I decided to start over checking the pins again on each motor lead & got the first one to home last night, which is progress. It lookalike the board is still good,which is the main thing as I was kind of worried there for a while.