microseconds_per_step_pulse

smoothie-forum
(Ken Gentry_SW) #1

I have three external drivers on my large CNC mill (one for X, two for Y axis and Z runs on an internal driver) and am getting some missing steps. I just upgraded this machine to two-start lead screws with anti-backlash nuts and did not have missing steps when X and Y were running slowly off the internal drivers. I purchased 2M542/STM5045 external drivers and running two 36 volt, 9.7 amp power supplies (one for the Y steppers and the other for for the X stepper).

While reading recent forum posts I saw the following and wonder if I need to increase my microseconds_per_step_pulse setting to 2.

“I also increased microseconds_per_step_pulse = 2 in the config file because the M542T datasheet recommends a 1.5 micro-second pulse as a minimum”

Anyone mess with this setting? Are there other related settings that would need adjustment as well? I’m running the drivers at 3200 steps/revoution. Should I drop this to 800 steps/revolution?

Any info on this is greatly appreciated,
Ken

Imported from wikidot

(BLB2015_SW) #2

Hi Ken,

I used a M542T recently on my printer. I found that 800 steps/revolution and a setting of microseconds_per_step_pulse of 3 worked. I also tried 5 and 10 as a setting and didn’t see a difference in performance. As an FYI I was running at 24 VDC with a NEMA23 stepper.

(Ken Gentry_SW) #3

Good deal. I’m using 300 oz in, 3.0 amp NEMA 23 steppers.

Thanks for the setup tips.