Mac OS X update and Gerbil errors code 22

I have been using my mini gerbil for about a week with the new installation and all was going well. My mac picked up the USB port and I was able to cut several projects and etch out several more images. Then an update came through on the Mac OS X and the mini gerbil still homes, moves, everything manually. However, trying to start a process in Lightburn ends up with the following error.

Starting stream
G00 G17 G40 G21 G54
G0 X0 Y0
On or near line 4:
Stream completed in 0:00

Any help on getting this to communicate properly would be great! Everything else checks out good.

Replying to myself because I found the issues. On a K40 laser the anode high voltage line puts out a very high amount of RF energy if it is physically attached instead of soldered. The laser voltage line from the power supply also likes to curl lick a pigs tail which also creates a large EM field while firing. This is enough to interfere with the Mini Gerbil communications USB to the computer. This is why the program will run fine with the laser turned off, but when it is on, the program is interrupted when streaming from the computer through the USB cable.

Things I did to solve this.

  1. I used Kapton tape to wrap the high voltage line so that it would not curl into a coil.
  2. The Mini Gerbil box was enclosed in metal tape (like that used in HVAC ductwork).
  3. The USB cable was also wrapped with metal tape from the Mini Gerbil connector to about 3 inches outside the K40 Laser casing, where the USB cable comes in.
  4. Heavy Silver solder with Indium added was used the secure the high voltage lead onto the laser anode from the poser supply.

In essence, everything is shielded and locked down. I have had 15 successful runs with no interruptions or issues with the system.

No drivers were changed or added. It works on both the Microsoft system and my Mac OS X. Lightburn is phenomenal to work with along with this Mini Gerbil board.

Highly recommend shielding everything from that high voltage line and making sure you are not creating high amounts of RF emitted radiation.

1 Like