Loosing steps sometimes on all axes at the same time

Hi, I’ve got an issue currently, where the printer suddenly starts loosing steps on the X, Y and Z axes at the same time. I think also on the extruder but I’m not quite sure about that one. Here is an example video and some photos:


I’m very sure it’s not a mechanical issue. I just printed a test cube sliced with perimeters and infill at 100mm/s. That should be much more demanding then the slow (30mm/s) circles in the video. But everything was fine. Also it is weird that it’s happening on all axes at the same time.
This also resulted in the nozzle slamming in and dragging through the bed because it seemingly lost steps during z-hops.
The issue also comes and goes without me changing anything. But it seems to have something to do specifically with the model I’m trying to print currently.

This is a dual extrusion print. And it is a large(ish) file, about 14Mb. I’m not sure if this has something to do with the problem yet.

What I already tried:

  • Resliced, reuploaded to SD-Card
  • Downloaded from SD card and checked file integrity
  • Tried to print from PC instead of from SD card
  • I tried printing the problematic section without the rest of the file

This all resulted in the same issue at the same time. But the issue only appeard when the first extruder was active, not the second.
So I tried printing only the problematic section again and manually switched to the second extruder before (Toolchange command). The second extruder was used, the offsets were correct and the issue was gone. I switched back to the first extruder and the issue did not reappear. Now I could not make it fail again. Also not on the original file.

Now, one day, later the issue is back. It only appeard again after reslicing and uploading a new file. The old one was continuing to work fine.

My feeling is, that the printer tries to run the correct path, but much to fast. In one of the images I marked a blob of filament with a red circle. This is one layer of the prime tower which can be seen right beside it. The printer tried to print it much less than one second. I would almost say there was no delay at all between the steps. Or that’s what it feels like at least.

I read about undervoltage as a potential cause for loosing steps. My powersupply is good for 190W and I think that should be plenty with no heated bed. Also if this is the issue, it still should take the same time to print something.

I did not change anything in the configuration since quite some time. So far everything has been working fine for a long time.

I am NOT on the newest version of Smoothie. This is a bit difficult because I have a Cetus (Tiertime) printer and use a aftermarket Tinyfab controller which is specifically for converting Tiertime printers. There is no newer version released for it. I would need to build it myself. I’d like to only try that if necessary. The current version seems to be from April 2018.

Has anyone got some ideas about this?

I have done some more testing on this issue. It looks like every time I modify the contents of the SD card the print will fail afterwards. By that I mean if I upload or delete a file from the SD card the print fails. Even if I do not print from the SD card and even if the modified file has nothing to do with the print.
So I now solved the problem by uploading the file to the printer. Then I turn the printer off and on again and now it prints fine.
What could be the cause for this issue?

Do you mean you are accessing the SD card ( writing or reading ) while you are printing ?!

No, I copy the file onto the card or delete it (using USB Mass Storage) and print afterwards

Maybe try reformatting the SD card?

I tried to do some further testing but now I just can’t reproduce the issue. After not being able to get rid of it for three days in a row, now I don’t manage to get it back :roll_eyes:
I did not reformat the SD card yet. Before I try to fix it, I want to be able to reliably reproduce the issue, so I can be certain it is really solved.
I guess I need to wait until the problem appears again. (Or just hope it doesn’t…)