LED 2

smoothie-forum
(AidanP_SW) #1

Hi ,
This is my first post.

I have just started to use my smoothieboard for a CNC application. I had all 3 axis running smoothly and homing correctly. I had issues with the limit switches and in trying to sort that problem I seem to have caused another problem.

I cannot remember the sequence of events but (I think the Z axis overshot) but as a result all axes started to move very roughly (missing steps?) I noticed LED 2 was off. I reset everything and homed the z axis it seemed to home smoothly, however when I tried to move the z axis upwards it was very rough again. I looked at the lights and LED 2 was solid.

I have searched here and a solid or off LED 2 is a firmware issue. I would appreciate any help on how to solve problem.

Imported from wikidot

(AidanP_SW) #2

I ‘ve done some more investigation on this problem without success.

Problem: I had all 3 axes operating smoothly and homing correctly. Now all motors hardly move. After turning off power LED 2 stays solid. After resetting all the LEDS are correct again until I try running motors again.
Tests

  1. I have checked all 3 motors the coil resistance are all the same as original suggesting they are not damaged. Measurements were taken at the plug to smoothieboard so wiring between motor and board is still ok.
  2. I measured the voltage to smoothieboard, it was 21V which is a little lower than 24v but would this account for the motors struggling to move?
  3. I downloaded a new version of config file and I still had problem
  4. According to the troubleshooting page if firmware is problem both LED 2 and 3 are solid. Only LED 2 is solid on my board. Does the firmware become unstable if it previously worked? I don’t want to unnecessarily change it if that is not the problem.
  5. What does LED 2 actually indicate?

I would appreciate any comments or suggestions what to try next.

(Arthur Wolf) #3

Hey there.

Can you please try formating your SD card, and setting it a-new with the latest edge firmware, latest matching configuration file, and modify as little as possible in the configuration file, and try again ?

Cheers.

(AidanP_SW) #4

Arthur,
Thanks for the reply. I reformatted card, installed latest firmware and config files but I still had same problem. I had concerns about power supply so I changed it. Eventually everything ran smooth and all axis home, so I’m pleased to back where I was. The replacement PSU I had was only 2A, it doesn’t matter for testing individual axis, but in operation are more than one motors operating at once?

I noticed that LED2 flashes or is solid/off dependant on whether the smoothieboard is receiving information. Is that correct?

I still have issues with limit switches and setting Z height so I need to get a better understanding of these settings.
Thanks for your help

(Arthur Wolf) #5

Hey.

2A is definitely not adequate at all. You want at least 2A for each stepper motor driver. And then some more for hotends, heated beds, or whatever else.

LED2 doesn’t mean anything useful unless you are actually coding for Smoothie, it’s not useful as a debugging tool in the situation you are in.

(AidanP_SW) #6

I should have reported back, replacing the faulty power supply solved this particular problem.
Thanks