LaserWeb Appimage available?

I am looking at the install instructions at

It references downloading the appimage from https://github.com/LaserWeb/LaserWeb4-Binaries/releases but I don’t see one there.

What’s the current expectation for using LaserWeb on Linux?

Is it to follow the “manual” instructions for Raspberry Pi?

I had Laserweb4 running on a Rpi and connecting through wifi versus a usb cable but its been quite a while since I used LW4. From what I remember I used the console on the pi to install the comms server and hosted the frontend on my desktop. I think the one I used was 4.0.996-134. The install instructions i used and was successful with was these: https://laserweb.yurl.ch/documentation/installation/36-install-raspberry-pi (Im glad I saved this bookmark lol it has been invaluable with LW4) Hope this helps :stuck_out_tongue:

I followed the Raspberry Pi instructions to install on my laptop because they aren’t specific to the RPi, but I don’t even see a CAM tab, it won’t let me apply a machine profile, and there’s no way I can see to do anything that isn’t laser. I’m seeing the same thing in Firefox and Chrome. So probably not the solution to my current problem. :stuck_out_tongue:

Are you wanting to use it for your CNC router?

Yeah. I have 38 SVGs that are outlines to contour through the stock, and eight or so also have paths to carve into the top with a V bit first. I want to gang them in a single job. Seemed like the b CNCWeb side of LaserWeb might be the right tool for the job, but with it not even letting me set CNC mode, probably not.

Following up: I gave up and tried using cambam. It was not a success because I couldn’t turn off dogbones. Also, cambam seems to get confused about units easily, and it doesn’t display the units it is using. I watched it mix metric and imperial with one on X and Y and the other on Z.

I got there because FreeCAD crashed reading SVG, and it looked like it was going to be extra work to lay out the parts into a single job, but cambam doesn’t read SVG at all, and it also handles only one file and can’t gang them together, so I ended up using inkscape to gang them and export DXFs, Also, the paths that cambam created were really odd to me; bouncing over my parts to do random outline sections rather than recognizing sections that were connected and going smoothly from one to the next.

So I went back to FreeCAD, and found out “Pad: Result has multiple solids. This is not supported at this time.”

sigh

@mcdanlj Have you tried linuxcnc?

http://linuxcnc.org/

I’m a bit confused here; I’m not aware of linuxcnc being a tool for generating toolpaths from an SVG or DXF.

@mcdanlj I apologise for the confusion.
I should read a thread more thoroughly before offering a reply!
I have read that Carbide Create works well with Wine.

Sadly, Carbide Create doesn’t believe that machines as big as my 1000x1500 OX exist.

The last AppImage is published here: https://github.com/LaserWeb/LaserWeb4-Binaries/releases/tag/untagged-4818330b6baa8213d4a7. It’s not the newest version, but there was not so many changes since.

It should also work by only installing lw.comm-server manually (following the Raspberry Pi instructions) but this includes an even older frontend.

If you just need the CAM to generate gcode, you can use the online version at: https://laserweb.github.io/LaserWeb4/ (This version cannot directly connect to a machne!)

1 Like

I don’t see any way for that to actually enable CNC mode. I’m sure it’s hidden somewhere, but I’m not finding it now any more than I found it last time… I just see it set to false in configuration and don’t see how to change that.

The CNC-Mode flag was removed long time ago, because it’s not needed. You just have to select the correct CAM operation (like “Mill Cut Inside”).

1 Like

Aha! Progress! Thanks.

I’m told that The file has minor issues. Please check document is correctly loaded! without information on what “minor issues” are. This document has two layers intended to be two operations; v-carve / engrave in one layer, and mill cut outside on the other layer. I don’t see any layer selection in operations, so I guess I have to break apart the file into multiple SVGs, one per layer, correct?

The operation setup section doesn’t scroll, it just runs off the end of the page. I’m using a 2560x1440 monitor and I have to go to full height to see all the setup options. I see that it scrolls if I tab from one item to the next, but now I can’t scroll back up, because there is no scroll bar and it doesn’t react to drag scrolling. Am I missing something else?

This warning has something to do with the file format and the used SVG parser. In most cases it still works :wink:

You can drill down the object structure of the file by clicking on the plus sign in front of the loaded filename. Alternatively you can select an object with the mouse in the 2d/3d space. But my advise would be to use different colors instead of layers. This way you drag the whole file to the operation and use the color filter to select which part has to be used.

There seems to be a “feature / bug” in newer browsers which causes the missing vertical scroll of the operation range. Unfortunately I don’t have a quick solution for that.

1 Like

I wonder if it dislikes it being an “inkscape svg”?

Anyway, selecting g: layer1 and g: layer2 I was able to tell which layer was which, and drag them separately to create the two ops, which was much better for me than going back and adding colors. I’m first v-carve engraving a few small features on top of stock, then going in a separate operation to mill cut outside lots of parts, out of which only a few have some features on them.

With no tool library, I have to edit in tool changes for camotics to know what tools to simulate. Camotics isn’t showing me enough resolution to tell whether carving would be successful, but at least laserweb is not creating the dogbones that dogged me in cambam! :slight_smile:

Unfortunately, the layer with a few lines to v-carve gave me an empty job. I think maybe I don’t know how to set up v carve operations.

; Operation:    0
; Type:         Mill V Carve
; Paths:        0
; Direction:    Conventional
; Rapid Z:      1.5
; Start Z:      1.5
; End Z:        0
; Pass Depth:   1.5
; Plunge rate:  300 mm/min
; Cut rate:     600 mm/min
;
; Retract
G0 Z1.500

That’s the entire operation. Having an End Z of 0 it makes sense that it wouldn’t do anything, but there’s no option for End Z that I see in the UI:

no-end-z

The v-carve operation needs outlines around forms (closed objects) to v-carve the inner part. It’s like mill inside. Single lines will not work.

Oh, v-carve is for chamfer, thanks. What operation(s) can cut single, unclosed, lines? I see that at least Mill Cut can, and seems to have done what I expected. :slight_smile: