Laserweb 4.0.999 halts

When I change the gridspacing under “Application” all of a sudden Laserweb halts.
After a moment I closed the program and started it up again.
The screen with the black square apearse en then goes to white and nothing happens anymore.

Reïnstalling does not help
Even go back a version does not help
This happened on two different laptops.

On one laptop Laserweb worked for a week until I changed the gridspacing.
Cannot give anymore like settings etc while Laserweb does not work on my laptops anymore

Thanx in advance for any help on this one

Hoi @Frisian

This is something I think I understand.

There is a bug/workflow error going on as you edit the value, it think it gets briefly set to ‘0’ as you start typing, and this causes LaserWeb to lock up as it tries to draw an infinite number of grid lines in your web browser.
And, even worse, it has saved this value to your local machine settings in the browser. So if you restart laserweb the bad settings get resurrected and the app instantly hangs again.

The Solution is a bit painful, we need to delete the cookie with the local cached settings. This is a pain because you loose all your settings unless you have saved them to a machine profile file on disk. Sorry.

If you simply connect via a normal web browser to use laserweb you can use the ‘clear cookies’ function you get when clicking in the address bar.

However; I am assuming you use the LaserWeb App, which handles the web browser stuff internally. You need to delete the main settings file on your disk before it will start again properly; this should be at:
Windows:
C:\Users\<user>\AppData\Roaming\<yourAppName>\Cache
Linux:
/home/<user>/.config/<yourAppName>/Cache

Where the app name is ‘LaserWeb’ (I dont have a install to test this, so look and check yourself…). Remove the contents of that folder. You will then nedd to re-configure LW from scratch.

2 Likes

Really thanx for very quick response.
You put me on track here
When I followed your instructions I could’nt get it working
Only after I also removed lw.comm-server and reïnstalled Laserweb came back to life.
Glad to be working with Laserweb again

1 Like

@Frisian , glad you got that working again. Killing the bad cached settings (by any means) is the trick to recover from this.

You can use the up-down arrows beside this field to adjust it safely, just never let the value get blank or 0.

For posterity:
The issue is not actually with the grid lines, it is with the grid numbering. Which is continually re-drawn as the value is being edited.
The line drawing routines have a (simple) protection mechanism that limits the value to 1mm even if it is set lower in settings. But the grid labelling routine does not have this, and can get stuck in a loop trying to draw the same number repeatedly.

I’ve made this available in my fork/preview.

2 Likes

Thanx again for explaining and picking this up.

I hope this is also helpfull for other users as well

Met groet,
Simon Nieuwenhout

1 Like

Does anyone know how I can clear the cache on a Mac?
Thank you for your help!