Laserweb 3 on Linux - can't see USB connection Hi - last week I

Laserweb 3 on Linux - can’t see USB connection

Hi - last week I tried out my newly built Eleks Maker L5 laser thingy using benbox and their driver, from my Win 10 PC… and that was working ok.

This weekend I’m trying Laserweb3 using Ubuntu running on a netbook, and I can’t get LW3 to see that the nano is connected. There’s no choices presented in the ‘select port’ dropdown when the USB port is selected.

My Steps

  • moved the laser jumper under the nano
  • using Arduino on the netbook, built and uploaded grbl 1.1f to the nano
  • using the Arduino terminal (112500), I see the grbl prompt from the nano after reboot, and I get response from the help ($) prompt
  • quit Arduino IDE, start node server, launch chromium on proper URL
  • the Laserweb3 GUI comes up, but there’s no choices available in the ‘select port’ dropdown.

So, to me it seems that the nano has been properly flashed and is responding over the USB. Is there an extra driver required in Linux so that the usb/serial connection is recognized in LW3?


Update - I have the exe version of LW3 on my Win10 laptop, and I just tried that with my engraver… and that worked! So that at least proves that the grbl has been flashed correctly, so my problem with linux is somewhere between the USB input and LW3.

+Peter van der Walt - thanks for the suggestion. I haven’t yet checked the syslog, because I assumed that if the Arduino upload and then the serial console worked, then there was a suitable driver in place.

The stuff’s put away now but I will check that log when I next try it.

I was going to suggest you check permissions on the serial device node (probably /dev/ttyUSB0 ), but it doesn’t sound like it’s that sort of issue. If the arduino loader works for the same login, the problem is elsewhere.

@Richard_Betel - thanks. Today I briefly tried the setup again. I tried running the node server.js as root, and I tried (but failed) to launch the chromium browser as root.

syslog has no information; after bootup it exclaimed with joy about finding OpenGL, and confidently assured me that LW3 would run optimally on this device. No other information came up as I connected/disconnected the USB cord from the laser engraver.

For the time being I can run successfully from my Windows laptop, but I’m hoping the Linux netbook can be assigned semi-permanently to the laser. Is LW4 working in Linux now?

You don’t have to use the same login to run node.js and the browser. I’m running lw3 as user “laserweb”, but I log in as “richard”. Chrome doesn’t like running as root…

I’m just getting back up to speed on lw4, so I can’t answer any questions about it yet.

I’ll poke around for the logs. I think they’ll be in their own file somewhere.