Laser tube electric problem

Hi there,

Noob here :grin:
I just got my k40 in the mail.
I set it up and tested the laser tube with the test fire button no problem.
Wen i use k40 wisperer and send a file over to the machiene the laser head moves but the laser is not firing .

Wat cane this be ?

Sorry fore my bad english 🤷🤦

There are a lot of possible causes for this behavior.

  • The “Laser Switch” is not ON during the job
  • Something is set up wrong in K40 whisperer
  • There is a wiring problem between the controller and the Laser Power Supply (LPS)

Please provide these pictures of your machine:

  • The control panel
  • The connector side of your LPS
  • The wiring between your controller and the LPS
  • The back of your control panel showing the wiring


  1. What button are you calling the “test fire” button?
  2. What are you trying to image with the job?

@Scorch is there any setting in Whisperer that will stop the laser from firing during a job?

I hope this is wat u ask fore .

Tis is the test switch u see on my panel the laser switch is on and with the test switch it works

I tested a few images and a basix square with a circle and a star insite al in the colors to vector cut or vector engrave or raster engrave non works .

Thanks fore the help

Thanks for the pictures.

Have you tried imaging with the stock software?

Can you post a picture or video of the panel while the job is running?

I cant share video’s becaus im new here .
But u mean from the control pannel ?

Yes a view of the control panel. A photo will work just take it while the job is active.

Your current regulation pot seems to be set a minimum?
Turn the pot up past the middle and see if that changes anything?

I assume you are running coolant?

Yes i am

I turnd the Am up wil it was working noting changed .

Have you tried imaging with the stock software?

No i started with k40 i was not intending to try the stock software .

Maybe i put the wrong firmware on ?

Do you mean firmware on the controller or the program on your PC?

The k40 wispere askt me fore new firmware on my k40 i think ?

I do not use Whisperer so I do not know. I thought it worked with the stock controller firmware?

@Scorch can help here …

You cannot change the firmware on the board. The K40 whisperer installer does install a driver on your computer to allow the K40 Whisperer talk to the controller.

If K40 Whisperer is successfully controlling the motion the driver/software is installed correctly and working.

If the laser does not engrave/cut during engraving/cutting during the motion it is not a software problem.

Thank you fore helping out.

From the pics it looks like the laser switch and test button wires are swapped.

@donkjr can you look at the pics to verify?


Oh my not again !!!
I am checking…

Yup, the wiring is swapped! Wrong up on the panel this time!

@NielsA swap the wires that go to the “laser switch” and the “Test Switch”

Should look like this: