Laser Raster option generated the gcode with S value to small, 0.1 - 0.7, instead 10 - 70

Hello everyone,

First of all CONGRATULATIONS to all developers for this awesome software, I love the futures, and easy of use (after wathing a tutorial :smiley: )

I made a few engraves from an dxf file, came out quite nice, but now I wanted to test a sample raster photo, and the generated code seems to have the S parameter to small, the range is around 0.1 - 0.7. The light on the laser doesn’t turn on on such low Power settings.

I pasted a sample code the was generated, with the Min Power set to 50 and Max power set to 100:

G21         ; Set units to mm
G90         ; Absolute positioning

; Pass 0

; First Move
G0 X0.03 Y0.03 
; Generated by LaserWeb (lw.raster-to-gcode.js)
; Size       : 0 x 0 mm
; PPI        : x: 300 - y: 300
; PPM        : x: 0.0846666667 - y: 0.0846666667
; Tool diam. : 0.1 mm
; Feed rate  : 600 mm/min
; Beam range : 0 to 1
; Beam power : 50 to 100 %
; Options    : trimLine, joinPixel, diagonal

G1 F600

G0 X0.03 Y0.03 S0.0000
G1 X0.08 Y-0.02 S0.7575
G0 X0.13 Y0.03 S0.0000
G1 X0.03 Y0.13 S0.7575
G0 Y0.23 S0.0000
G1 X0.23 Y0.03 S0.7575
G0 X0.33 S0.0000
G1 X0.03 Y0.33 S0.7575
G0 Y0.43 S0.0000
G1 X0.43 Y0.03 S0.7575
G0 X0.53 S0.0000
G1 X0.03 Y0.53 S0.7575
G0 Y0.63 S0.0000
G1 X0.08 Y0.58 S0.7595
X0.63 Y0.03 S0.7575
G0 X0.73 S0.0000
G1 X0.18 Y0.58 S0.7575
X0.08 Y0.68 S0.7595
X0.03 Y0.73 S0.7627
G0 Y0.83 S0.0000

On my previous test, where I engraved with Power set to 10, the gcode looked like this:

G21         ; Set units to mm
G90         ; Absolute positioning
M4 S0       ; Enable Laser/Spindle (0 power)

; Operation:    0
; Type:         Laser Cut
; Paths:        8
; Passes:       1
; Cut rate:     800 mm/min

; Pass 0

; Pass 0 Path 0
G0 X129.00 Y94.00
G1 X10.00 Y94.00 S10.00 F800

; Pass 0 Path 1
G0 X10.00 Y94.00
G1 X9.88 Y94.00 S10.00 F800
G1 X9.75 Y94.00
G1 X9.63 Y93.99
G1 X9.51 Y93.99
G1 X9.39 Y93.98
G1 X9.26 Y93.97
G1 X9.14 Y93.96
G1 X9.02 Y93.95
G1 X8.90 Y93.94
G1 X8.78 Y93.93
G1 X8.65 Y93.91
G1 X8.53 Y93.89
G1 X8.41 Y93.87

Any ideea why the S is so low when I used the Laser Raster setting?

Thank you!

nobody around to give me some hints what I could tweak to have an usable gcode with my laser, cand someone else tell me if they ware able to use the engraving gcode, had the S parameter with values so low ? Did your laser controller handled the gcode with so low values for the S parameter ?

Thank you in advance

Go to settings / gcode and configure the “PWM MAX S VALUE” to the value your controller needs for 100%.