Laser not working when control wiring plugged into LPS

@donkjr Hoping you can help me out. From all the posts I have read, you seem to be the most knowledgable so if anyone can do it, it would be you.

Here is my issue… the laser will not fire using the pulse key on the digital panel. I checked the Laser Power Supply (LPS) and found the following. With all connectors plugged in the “P” led on the LPS is lit. Pressing the test button on the LPS makes the “L” led comes on but the red “Laser” led does not come on and no laser is emitted from the tube.

I unplugged the control board connector from the LPS, obviously, the “P” led went off. Pressing the test button on the LPS makes both the “P” and the “L” leds come on, the red “Laser” led comes on, and the laser is emitted from the tube.

My initial thought is the water protection (WP) sensor is bad. I traced the wires from the WP sensor to the board to be sure they were labeled on the control board properly. They are. I disconnected the WP sensor connection and jumped a wire from the WP port to the ground on the control panel. I plugged the control board connector back into the LPS and tested the test button on the LPS. No change was noted. I checked the pulse button on the control panel and no change there either.

My LPS is MYJG-60W. Here is a link to one just like it.

Any help would be greatly appreciated. I am not sure where to go from here.

@Hammbone,
When answering the questions below please reference my question #'s, this is so we can stay in sync.

Note: You can use the “Quote” function to make answering easier.
While the reply’s edit window is open highlight the target area on the post you are answering and click the " "Quote" indicator that comes up. That will copy the highlighted area from the source post to your reply’s edit window where you can add your answers.

Background

  1. Is this a K40?
  2. Did this machine work properly before these symptoms were presented?
  3. How hard do you run the machine?
  4. Has there been any other operating events like; tube overheating
  5. What coolant are you using?
  6. Do you have a DVM and are you knowledgeable on its use?
  7. Does your machine have a “digital” control panel?
  8. Do you have a stock controller?
  9. Have you made any mods or other upgrades?
  10. Do you have a milliamp meter on the machine?

Visual Information

Please post these pictures:

  • The connector end of the LPS
  • Control panel
  • Model # of the controller

Verification of symptoms

(please verify by responding with yes if the statement is true or no if it is not)
10. The laser will not fire when the “Laser Test” button on the digital panel is pressed?
11. The laser will fire if the “TEST” button on the LPS is pressed?
12. The “P” light is lit when the LPS is plugged in. Pressing the “Laser Test” button on the control panel lights the “L” LED on the LPS but the Laser does not fire?

Diagnosis

I suspect that something is wrong with the power control on the IN pin of the LPS.
The LPS power is controlled by a 0-5V signal on the IN pin. Digital control panels typically send a PWM signal that is proportional to the power level set on the panel. i.e if the panel is set to 50% the signal on IN is 50% DF.

Troubleshooting

  1. When #12 above is true what is the digital power setting on the control panel?
  2. When #12 is true what is the voltage on the IN pin?

You can measure the voltage on IN with a DVM
OR
You can tie the IN pin to 5V which will simulate MAX power. Then try the control panels “Test” button again. Verify that the laser does or does not fire.

2 Likes

Thanks again for all your help so far.

1 Like

Thanks for answering all of Don’s questions. You would be amazed at how hard it is to get the information from some people. And once your problem is solved, please stick around and peruse the forums, there is a wealth of information and ideas contained here. :slight_smile:

2 Likes

I think that completes all the questions but if I missed something let me know.

@Hammbone nice job on the questions!
This will help a lot as its hard to troubleshoot these things when your not in front of the machine. It’s easy to miss visual hints :slight_smile:

Summary so far…

It seems the laser power supply is working properly in that it operates with the test button down on the supply.
That is: if the answer to question #15 & 16 is yes.

Note: internal to the LPS when the local test button is pushed the P [WP] and L signal inputs are simulated so all of the control inputs are essentially bypassed. That is why the “L” LED comes on. I believe the L signal should also come on when you push the Pulse button on the panel.

  • The above seems to hint that the start of this failure is somehow related to the water sensor.
  • That said all indications are that the enable signal P is OK
  • However the L signal is not asserted when the Pulse button is pushed.
  • We will do some further verification tests below.

I do not have that controller nor panel so I am not sure how the “pulse” button is implemented. I suspect when you push the “Pulse” button it asserts the “L” signal and the laser will fire if the P signal is is in the correct state. I will do some more research on this.

We can still test the “L” port on the LPS… see below.


  1. When you pressed the Test button on the LPS and the “L” led lit up did the Laser fire?
  2. When you pressed the Test button on the LPS and the “L” led lit did the “P” also light?

Testing the “L” port on the LPS

  • Turn the machine power off
  • On the LPS: disconnect the wire that is on the input to the “L” pin
  • On the LPS connect a short, about 3", wire to “L”. We are going to jumper the “L” port to “G” which should simulate the controller turning on the laser.

With the power on and the laser enabled, briefly touch the jumper that is connected to “L” to the “G” pin.
17. Does the laser fire while the L jumper is connected to G?
18. Does the P and L led on the supply illuminate?

LPS DC Measurements

Setup:

  • Power on
  • Laser enabled, interlocks closed
  • Power set at 50%

Static Test of Inputs

On the LPS measure & record the DCV on these ports:

  1. L
  2. P
  3. G
  4. IN
  5. 5V

Dynamic Test of Inputs

  • Briefly push the Pulse button on the control panel
  • On the LPS measure & record the DCV on each of these ports while the Pulse button is pushed
  • You may need a second person to push the Pulse while you use the meter :wink:
  1. L
  2. P
  3. G
  4. IN
  5. 5V

Research on Ruida control of LPS

@Hammbone it sure seems that the L signal is not being asserted on your machine.

Should have asked earlier…
29. Does the laser fire when running a job vs the Pulse button?

Research suggests to me that:

  • The P [WP] control on the LPS is not connected nor used by the controller. Your pictures show that your P signal is jumpered to G. Unless there is an internal LPS problem P is likely not the culprit.
  • The controller controls the LPS using only the L and IN ports on the supply.
  • The WP input of the controller uses a 24VDC level
  • I expect that:
    ** Power Level is controlled with the PWM signal LPWM1 which is connected to IN
    ** All Laser fire is accomplished using the L signal. This is true for normal imaging and the pulse button.
  • Coolant sensing is done directly by the controller which in turn inhibits the assertion of the L signal if:
    ** water flow is not sensed
    ** a chiller (if connected) error occurs.
  • Theoretically, the controller could also lower the power level on the IN pin.

WP control & settings

In the manual, it seems you can use the Diagnosis function to read what the controller thinks the state of the WP signals are?
I would try that to see if that gives us a clue.

WP Enablement

This section of the manual says “when water protector 1 is enabled”.

In section 9 of the manual

Water protection enables: When the water protection enabled, the controller must connect the wiring,
otherwise the machine will not emit laser. If disabled, no need to connect the water protect wiring,
the controller will not test.

I would reccomend you look at the WP enablement setting and diagnostic for clues.
You could also disable WP checking and see if that allows you to fire the laser?


Supporting Info

My estimate of your wiring:

Signal defintions from the manual:

I am currently going through the diagnostics info you shared and will report back what I find. I am getting called back into to work atm.

Interesting Results;

note: I am assuming that the collected voltages are NOT negative as indicated by the -.

Static Tests: this looks good. Note that the IN signal = “0” meaning that the controller reduces power to 0 when the system is idle even though L is not asserted.

Dynamic Tests: looks strange, L is not asserted (=5V). This should be low assuming the Pulse button is supposed to fire the laser?
These results suggest that the controller does not assert the L signal with the Pulse button or the controller is not properly asserting the L signal.

This suggests that L is not being asserted when a job is running and there is a problem at the controller level. Note that power (IN = 2.5) has changed from the static test and is properly asserted.

Yet, this suggests that the LPS is not working because placing L at ground should fire the laser!

The previous L test is invalid

As seen above the IN pin is held at 0 during idle times. Therefore the test of manually grounding the L may not be a valid test of L as the IN pin is at 0, i.e. no power. This is further supported by the fact that grounding the L turns on the L LED but the laser does not fire. It’s actually firing at 0 power. Therefore we need to ensure that the IN pin is not 0v when we manually test L.
But why would the controller change the IN pin to 2.5V when inhibiting the L pin?? The controller may assert a power value independent of coolant condition?

A Better LPS “L” test

  • Turn the machine power off
  • On the LPS: disconnect the wire that is on the IN pin
  • On the LPS connect a short, about 3", wire from “IN” to 5V. We are going to solidly jumper the “ IN ” port to “5V” which should simulate the LPS at full power.
  • On the LPS: disconnect the wire that is on the input to the “ L ” pin
  • On the LPS connect a short, about 3", wire to “L”. We are going to briefly jumper the “ L ” port to “G” which should simulate the controller turning on the laser.

My theory is that the LPS is working [30 & 31 will prove that] and for some reason L is not being asserted.
I am still thinking the water sensor jumper change as being related to this problem, somehow the controller thinks it does not have water flow and therefore never asserts “L”.

Is it possible that the WPI is expecting 24V vs ground (specs say ground) to show good coolant???

I would disable the Water Protect sensing in the settings and see if this temporarily fixes the problem.
32. Has the water sensor checked bad??
33. Check the WP1 pin on the controller is it truely ground? With power off I would measure continuity (ohms) to ground.

I think you are certainly on to something. I can not figure out how to turn off the WP sensor on the panel for the life of me. Also, LED 14 “run” on the controller is flashing. Does that indicate anything worth noting?

OK :grinning: looks like the LPS is working and the controller is not asserting the L signal for some reason.

I will look around the manual and look for hints but I do not have one to try. I am running smoothie.

34.Does the L singnal at the LPS get asserted with the pulse? You could also measure the voltage on L at the controller (L-ON1) with power on when you push the Pulse just to make sure there isn’t a weird wiring problem between the controller and the LPS

LED 14 blinking is apparently a normal run indication.

@mcdanlj is there a way to ask the entire membership something i.e.“Do you have a Ruida controller and can you help with these controller symptoms?”

@funinthefalls are you running a Ruida controller?

Web research

From one of the posts in this link

  • Looks like you get to the machine settings from the software?

**IGNORE as you have done this: bypassing water protection is at your own risk… be shure that the water is really running through the laser tube…

**IGNORE we tested the supply: some PSU have a button for test, this button ignore the condition of water, then first try this (if your PSU have this button) : press the button test just a minimun time and look if the laser tube is firing

INSTRUCTIONS FOR GETTING TO THE WP ENABLE:
if not, with the machine running and linked via network, open rdworks menu file / vendor settings (password RD8888)
a windows is open
tab vendor param / other
press button READ (read setting from the controller)
disable Enable protect (i think this is enough)
press button WRITE (write setting to the controller)
close the window
then do a test

NO IDEA WHAT THIS MEANS wire WP1- WP-2 togther??: If not work, with the machine off, put a cable between ground al WP1 and WP2 fisically in the controller
in the PSU, you need to do the same, cable between ground and WP
machine on
then do a test

*** all this for a posible water protection problem (because led 9)


Found a manual with more info on LED’s: https://www.academia.edu/37288820/Users_Manual_of_Ruida_RDC644XG_Control_System

image
image


  1. Is LED 9 on?
  2. Some hints on web searches suggest that interlocks can stop the Laser from firing are any open?
  3. Can you list what LED’s are illuminated?

From the previous controller picture above I am guessing these are on:
LED 15: 5V
LED 14: Run
LED 9 : WP1 indicator (does this mean good or bad water flow?)

38: When you pull off jumper does LED9 go out? EDIT: looks like LED 9 on means WP is ok)

EDIT: the WP LED being on, the LPS working suggests it not WP that is keeping this thing dead. Starts me wondering what else is telling the controller not to fire. Such as door interlocks?

1 Like

@Hammbone,
I found this drawing in manual and noticed that in your machine on CN2 there is a Yellow wire on this pin.
Also notice that you have a similar yellow wire on grnd. This suggests to me that this is the interlock circuit.

  1. Have to ask a stupid question, are you closing the interlocks when doing these tests :thinking:?
    However, I would think the controller would throw an error if the interlocks are open.

It also shows a Shot function on pin 4. You could try grounding that pin and see if the laser fires with Pulse.
Careful the laser may fire when you ground that pin. I do not know if it is an enable or a fire function.

Edit:
40. Disconnect the wire on CN2-3. Does it have continuity to ground when all the covers are closed.

I REALLY appreciate all your help. Not only am I hopefully getting closer to having it fixed, but I am also learning quite a bit about the setup. Thanks so much!

1 Like

I should have also included the “L” LED on the LPS does not light up with the pulse button. Only with the test button on the LPS itself.

We are both learning a lot … :slightly_smiling_face:
STILL NOT FIXED!

I am not sure what to try next :thinking:…yet.

So far we have learned:

Ruida Controller

  • LED 9: ON state indicates a good WP circuit.
  • LED-14: blinking is normal running condition
  • CN2-3: a low true interlock circuit
  • CN2-4: enables the laser to fire with the LPS test button
  • CN5-2: [L-On1] is a low true signal connected to the LPS-L pin
  • CN5-3: [LPWM1] is connected to the LPS-IN and controls power with a PWM signal.
  • CN5- 4: a low true signal used to detect good water flow
  • Water protection: can be disabled from the driving software: RDworks, LightObject

LPS

  • L: PWM controlled by the Ruida during a job and when pushing the Pulse button. To test the L pins ability to fire the laser, tie IN to 5V and then briefly touch L to ground.
  • P: the P is bypassed to ground at the LPS. The Ruida implements the interlocks and coolant protection by not asserting the L signal when these circuits are open
  • IN: when idle, IN is 0v i.e. no power. IN is set to the panel power PWM value when the Pulse button is pushed.
  • Local test button: will test laser supply is the IN pin it tied to 5V or CN5-4 is tied to grnd.

Did I miss anything… or get anything wrong?

Stabbing in the dark:

  1. Are the controller and LPS grounds at the same level, no resistance between them.
  2. What does the 24VDC read?

I’m starting to think the controller may have just gone bad…???

All of the info regarding the functions and such look correct to me.

Head over to this site https://rdworkslab.com/ they are about all things Ruida. They might be able to help out.

1 Like

@donkjr

Looks like I may have figured it out. After all this testing, it seems like it is simply a bad crimp on the pin connector of the GND, L-ON1, or LPWM1 wires. I’m not sure exactly which but I suspect it to be the L-ON1 connection. While pressing the pulse button and messing with those wires on the controller side I noticed the laser fire. I found I could replicate the laser firing by manipulating those wires. I probably should have tried to dial in which wire, but instead, I just swapped them all out for my own wiring. Everything seems to be working normally now. I was able to run a file, fire from the pulse button, and the LPS test button.

Thanks again for all your help!

3 Likes