Laser_module conf and test problems

goodmorning
i m trying to get lasermodule work with co2 psu.

the config is
laser_module_enable true
laser_module_pwm_pin 2.4
laser_module_ttl_pin 25
laser_module_maximum_power 1.0
laser_module_minimum_power 0.0
laser_module_default_power 0.8
laser_module_pwm_period 200

if I use the m1000 fire nnn or off it give me an error like fire is not present. g1 make axis moving without output from 24 and 25. I also tryied to invert both with ! without success. the firmware is the latest also with cnc version. someone had same issue?

There is so much wrong here I am not sure where to start.

First off can you please tell me what board you are using here, what firmware exactly, what version of the firmware exactly, and also I need to see all of your configuration file ( pasted to pastebin or pasted here as you prefer ).

A picture of your machine, of your board, and of your wiring, might also help moving forward so don’t hesitate to give them right away.

Also please tell me where you saw in the documentation that you should use “m1000 fire”.

1 Like

I’m sorry for the long time but I made many tests.
The board is a skr 1.4 turbo
The laser psu is a k40 one.
Wiring are correct because i compiled Marlin and was able to get working with laserburn controllino laser on off with a pin Digital and the power with pwm PIN…
With smothieware cnc firmware it seems that laser module can be enabled or not but When i run a test Cut it always send Signal to 2.5 pin. It seems to have locked this co f. I can manage endstop federate, axis direction but I cant control settings of laser module.
Any ideas?

@Arthur_Wolf asked for your configuration. I can’t imagine how anyone could even consider trying to answer a question about a particular pin without that; that’s kind of how smoothieware works. Note also that the Smoothieware developers in general are unhappy that the SKR board doesn’t meet their requirements and the manufacturer has not released the full design as open source nor contributed to the community. So they ask you to specifically ask the manufacturer for help first, before asking the community:

Here’s how you paste your configuration here. You need three back-single-quote character on a line by themselves, then the whole contents of the file, then another three back-single-quote characters, like this:

```
your configuration file contents go here
```
1 Like