Laser Fire Signals

I have been successfully running my K40 with RAMPS 1.4 with Arduino.
Recently it appeared to die half way through a print, the laser appeared to dim very quickly and then it just stopped.
I made the assumption that the tube had blown and put a new one in, this fired up very briefly and followed the same symptoms, so i changed the power supply!
I first ran a dry test (laser off) and everything worked fine, head followed correct course and completed cycle, I ran the test with the laser on (started at about 10mA) and after about 10 seconds it did the same again, laser went dim then off and it just froze, repeated same thing and it happened again?

One thing i had noticed when i changed the power supply i could not get the laser to come on, when pressing the onboard button on the power supply it fired but not through the Arduino, I traced the output to pin 6 and noticed this pin never went low to fire the laser,.
I disconnected the Arduino board and just tried to cycle that pin but it just floated at about 2.5v so i assumed the pin had failed, checked the same on pin 5 and it worked fine, so i changed the firing pin to pin 5 on the RAMPS board and it all seemed to work until i ran the test again (also remapped this on the Marlin software )

So now i seem to almost be back to square 1

  • The tube seems OK and test fires from the board

  • Power supply seems OK and has correct voltages

  • I am assuming the PWM is working as the cut is about 10mA, as expected

I am unsure where to go next other than to replace the Arduino Mega board but i dont know what is causing the root problem and what to test next?

Any help greatly appreciated

How (electrically) is the Arduino interfaced to the LPS?
I assume that it is a PWM signal from the Arduino.

Best to show us a drawing [schematic] of how the Arduino and LPS are wired. Include all the pins of the LPS.

Also, a picture of the LPS connectors would help.

Thanks for your response,

Hope this upload works?

So i am exporting models from inkscape using the ‘Turnkey Laser Exporter’ add-in using the format 60[ppm=30,feed=300], 60 was approx 13mA on the current, these were the cut settings for 3mm ply from my previous tube, when i ran at this i was experiencing the problems initially reported.
I dropped the power down to 10 and it ran fine (just marked the wood), now i have increased it to 40 (about 13mA) and it cut straight through!!

Could it be possible that the new tube and power supply are producing a better output than the original but requiring re-calibration?

Sorry, those diagram pinouts are unreadable.
Are you reporting now that it is working?

Yes, a new tube and LPS can provide higher levels of power.
What that would mean is for a certain PWM duty factor you would get more power.

This is an example of why we suggest keeping the adjustment pot when interfacing to the LPS.

1 Like

Yes I am up and running, just didn’t expect that much of a power change.
I see what you mean about the pot and will look at reinstating it .
Thanks again for your response