Large SVG not loading


I’m trying to use my laser cutter to do a cutout. For this, I converted a raster image to svg with Inkscape. The resulting SVG is rather large, about 7.6MB… (I attached it to this message)

When I try to open the SVG in LaserWeb (version 4.0.996), at first LaserWeb is blocked, it shows no reaction to whatever I click. During this time, the CPU load of of LaserWeb is about 23% so I guess it’s heavily working to load the SVG. But then after about 3 - 4 minutes the CPU load of LaserWeb goes back to 0% and the LaserWeb Window turns completely white.

Is there a problem in the SVG, or is it because the SVG is too large? If yes, what’s the size limit of an SVG to be used with LaserWeb? Is there a way to reduce the size of the SVG, e.g. by reducing the “resolution”, kind of like reducing the number of polygons in a 3D file? Or is there another program than LaserWeb which I can try to use with my grbl based Laser Cutter?


Large files can produce problems in LaserWeb, because LW is basically a webpage and therefore depends on the browsers memory. In case of the executable, there is chome embeded to run the frontend.

I would try to simplifiy the svg by using Path>Simplfy in Inkscape. You could also split the file into multiple parts to reduce the size of each part.

Thanks for your answer.
I tried Path>Simplfy in Inkscape, but it does something strange. I expected it to reduce the number of lines, making the path less smooth, or more angled which would be fine, but it turns the lines into strange, intersecting “areas” not suitable for cutting. :frowning:

(BTW, You probably want to shift-control-R to resize page to selection.)

And yes, what Path>Simplify does to that image looks like what I’ve seen from Path>Simplify in others. I recognize the effect.

Do you really want to cut it or engrave it? AFAICT it doesn’t have a single solid. It’s not obvious to me how a cut would work.

You could also try lightburn; it’s not free, but it has a 30-day unlimited trial so you could find out.

1 Like

Thanks for the tip with shift-ctrl-R, really handy!

I guess I’ll give Lightburn a chance when I have the time to play with this again. From the tutorial videos, it looks like a great tool.

About the picture: Yes I’d like to cut it, but I may have to try with something smaller first. It’s a “silhouette” or “cutout” (not sure if these are the correct words, we call it “Scherenschnitt” in German). Some very talented and patient people cut them out of black paper with tiny scissors. Nerds like me try to do it with laser cutters. :smiley:
Here are some examples:

When I tried to trace the shapes, it looked like you would end up with more than one piece, and I am used to silhouettes being only a single piece once they are cut. Probably I got lost in the intricate trace. :slight_smile:

It worked! :partying_face:

The problem was not (or not only) the size of the file, but my misunderstanding of how Inkscape creates paths. I started with a bitmap and used “Trace Bitmap…” in Inkscape to convert it to vectors. I should have stopped at this point and just saved it as a svg, but it still looked like the original bitmap, with all the black areas and I was afraid if i load it like that into LaserWeb, it will fill these shapes with black, but I only wanted it to cut the outlines. So I did another step in Inkscape, “Stroke to Path”. This gave me something that looked like what I wanted, just the outlines of the shapes. What I didn’t know was, that these outlines were not really 1 dimensional lines, these lines were actually 2 dimensional, they had a width, and because of that LaswerWeb web tried to create a path which goes around these lines, kind of like the outlines of the outlines. Which was obviously too much and wouldn’t have worked anyway.

So the solution is simple: stop after “Trace Bitmap…” and save as svg. If you want to look at the outlines in Inkscape before loading it into LaswerWeb you can do that by setting “Fill” to “No Paint” and “Stroke paint” to “Flat color”.

The resulting svg is 7 times smaller than the one that didn’t work. It still takes several minutes to load in LaserWeb and even longer to generate the gcode, but it works!

Sorry for the confusion and thanks again for your help!

1 Like