Kinda frustrated with my ignorance in all things Gcode, & CAM.

Kinda frustrated with my ignorance in all things Gcode, & CAM.

I am stuck without being able to do simple things in LW.

See this post:

I am trying to learn and test the tool chain.
I have created a simple 1 x 1 CAD in SU and exported a .stl. Then I load it into LW … we just stare at each other :).

Firstly, do I have to be connected to the machine for LW to work? I am not?

LW says it loaded the stl and added a tab “SlicedSTL1.5mm”. I left the default value of 1.5 when it asked during loading. I am not exactly sure what the slice value means/does. I am guessing that it created cutting paths a Z axis slice at a time. My file has no Z dimension as it is a 2 dimensional square. Note: I also tried all this adding a Z dimension and it behaved the same.

None of the tabs rendered anything on their pallet. In fact I have never seen anything on the Gcode or toolpath tabs even when testing Gcode.
The CAM tab shows the sliced file.
The Tree tab shows the sliced file listed but you cannot add an object from the object list to the tool path list below it.

So I am sure that my CAM ignorance is at play here but I am “hair pulling” trying to get to the next step.

Here is the syslog:
: Preparing Gcode File: Sliced STL1.5mm
: Estimated Distance: 0.0 m
: Preparing Gcode File: Sliced STL1.5mm
: Processing Sliced STL1.5mm
: Gcode Data Generated for Sliced STL1.5mm
: Preparing Gcode File: Sliced STL1.5mm
: Estimated Distance: 0.0 m

Can someone please UNGLUE me …

1- You don’t need to be connected for LW to generate gcode

2- STL support in LW is for slicing a 3D model, cut the slices and then build it from there. So slice value is the thickness of the material you are going to use

@Ariel_Yahni_UniKpty thanks. So if I create a .stl that is 2 dimensional and want to cut it from 1/4" material I set the slice to 6.35mm, (1/4").
But why is nothing happening with the .stl I am loading?

+Peter van der Walt that is what I expected it to do !!! What is wrong with mine?

Can you link me to that same file so I can try it?

+Peter van der Walt the SU and .stl file:

+Peter van der Walt when I exported from SU I chose ASCII.

+Peter van der Walt BW just noticed this error in syslog:
TypeError: self.onError is not a function ( on line 414)

+Peter van der Walt whoa just tried loading that .stl file in a different CAD program and it crashed. May be bad STL file from SU ???

+Peter van der Walt OK will try later got to go …

@donkjr ​ for simple cut paths use Dxf file format

I’ll definitely have to add this as a tutorial. I didn’t know that LW3 supported STL and slicing. Just did a search in the WIKI and didn’t see anything.

Cool stuff!

That is really cool

+Peter van der Walt
A report on my progress:
I downloaded the Guitarlist plugin.
…I got DXF and STL to load and operate but with some caveats.

I assume that STL slicing:
…creates a list of slices defined by the slice size through the part and the parts height.
…then you can select what slice you want to add to the tool path and then view a single tool path with the “eye” button.

What I found:
…I got the STL import to work but only with a 1x1x1 cube. It will not work with a 1x1 cube no matter what plugin I used. Seems other programs have trouble importing 2 dimensional STL files as well but they will error without loading. Maybe a 2 dimensional .stl file is just irrational :).
…Some slices render with open segments
…The “Preview tool path” button after defining a parameter for a single vector did not seem to do anything. IE: did now show a tool path view.

Clearly using .dxf is the way to go for 2 dimensional cutting it was just that prior to the Guitarlist plugin I could only export .stl with the free version of SketchUp.
Now I am learning SketchUcam :).

I found the following things compounded my poor understanding of how to import issues in LW for both DFX and STL files:
…The tabbed views (All layers, toolpaths, gcode view, Slicedxxx) aren’t always in sync with changes to objects and sometimes you need to click in and out of them to get them to refresh after making a change in, for example the TREE tab.
…The Tab “eyes” don’t always enable and disable the tool path views
and you can’t tell when an “eye” is selected cause it does not change color…
… Sometimes one or more of the tab views disappear including the source tab and only reloading everything will get it back.
… the last Gcode will remain in the Gcode tab even if you remove the object that created it from the pallet. . I.E. if you x out everything from the TREE and open a new file the previous Gcode will remain until you generate a new set of code for the newly loaded object.
… When you select the “slider” for an assigned “ToolpathVector” then change any value it does not persist after closing that dialog.