K40 X-Axis not working


I have just finished aligning my mirrors and now I want to control my K40 through K40 whisperer.

But whether I use the left or right arrow, the laser won’t move, I’d just hear a small noise.


Also, the Y-Axis seems inverted.

Finally, I have tried cutting a square and all I’ve got was a straight lign on the Y-Axis.

Anyone knows what might be the issue ?



Welcome to the forum.

What happens when you first turn it on - does it home OK?

While the machine is off, can you move the x axis without much resistance?

Edit : One cable wasn’t proprerly seated, it now works !!! :slight_smile: Thank you

Hello Jammy,

It doesn’t home ok, it goes only down and regarding K40 Whisperer preview, the starting point should be on the upper-left corner.

Also, if the laser is already at the bottom, it will try to go down anyway resulting in a scratchy motor noise.


I’d say that the X axis won’t move with as much smoothness that the Y axis, but it still moves.


Ok… your X axis is way too tight.

That could be belt tension, or a problem with the running gear. It should move as easily as your Y.

What is the history of the machine? Brand new? Second hand?

If your Y axis is travelling in the wrong direction, check the servo connection on the controller, it could just be in the wrong was around.


Thank you for the quick reply, one cable wasn’t correcly seated now it works :slight_smile:

By the way love your avatar, Gow 1 Gnasher Shotgun 4life :slight_smile:


It does look like the y axis is upside down.

On power up it should home to the top left until it sees the endstop optical sensor flag.
It goes bottom right???

Is this a new machine and has it ever homed correctly?

I would look carefully at the Y steppper axis wiring, ribbon cable inserted correctly etc.

1 Like

Crossed paths!!


Excellent :+1:

1 Like

Gears was great until 5 !