K40 Woes - Head moves, no beam

Hi Makerforums,

A bit of a backstory. I’ve got a spinal injury so a bit mobility limited. Had my K40 for a few months, it was working great until it wasn’t. Has had maybe 20 hours total use over 6 months.

First it would stop the beam randomly during jobs. It was at different spots and during different files.

I replaced the laser tube as it’s winter here and I worried a rare cold overnight snap while I was hospitalised had somehow broken the tube, new tube is aligned and focused. Intermittent power down of tube persisted.

Thought perhaps the door switch or safety switch were an issue so jumpered them out. Problem persisted and laser beam progressed and stopped all together. Test switch and PSU TEXT fire correctly and register well on the analog mA meter.

Replaced pot (waited a month for shipping). Test switch works, head moves for job, beam doesn’t fire. New pot is very pretty though! :slight_smile:

It’s the old style k40 with the analog meter and Nano board.

I’ve a programming background and electronics aren’t my forte. I’ve also tried k40 Whisperer on a Raspberry Pi and my Mac in case it was software related. I have a multimeter for diagnosis but no real idea how it works :slight_smile:

My thoughts are - psu? (Replacing that scares me.) Control board failing? Grounding issue (I’m in Australia and we do have a grounding pin in the power plug, and I can’t reach the little ground wire in the back to sand the powder coating so it’s still how it came new)? Something else I’ve missed?

Has anyone got any advice for this poor stressed out chick please? The laser is my hobby and has kept me sane while I go through treatment, not having it is hard smiles

Thank you in advance :slight_smile:

Well, the good news is that the PSU is fine. The fire button on the control panel fires the laser exactly the same way as the controller does. It pulls L to ground.

With the machine unplugged, check if all plugs are properly seated. Pay extra attention to the pin on the very right of the PSU and the big 4-pin plug in the bottom right corner of the M2 Nano. The pin on the very left (the one on the inside) is L.

2 Likes

Welcome to Maker Forums! We’re glad you made it here. Chances are pretty good for getting help.

For grounding: Is there bare metal anywhere on the case that you can reach? You could use your multimeter to check for conductivity between ground and any exposed metal on your case to determine whether it’s worth finding a way to improve the ground connection to the case.

Regarding the beam stopping randomly: Does it stop and restart randomly during a job? Or once it stops, does it stay stopped for the rest of the job?

Does this mean that the laser no longer fires during a job but it does fire with the test switch down on the supply?


Did the laser fire during jobs run with the whisperer?

Please post pictures of:

  • Control panel front
  • Control panel back showing wiring
  • LPS showing input wiring and connector
  • Nano showing wiring

Understanding the power supply :
Well it’s a bit more than just delivering power it’s also the trigger of voltage to the tube.
Donkjr rightly ask about the test switch, trying to split the problem as the logic M2 nano is not use to test fire, and bypassing any pot issue. your answer here would be very helpful.

From description your problem is intermittent, they are the worst to deal with, I could imagine 3 kinds of problems:
one on the 5V (which is a bit undersized in amp, do you plug other accessories here ?), underpower could failed your logic board like with a loss of memory. → check the 5V line, disconnect accessories (better power them from separated psu).
Second the 5V issue is a consequence, like if you have some arcing. (also could damage a capacitor in PSU, do not try to intervene here if electronic is not your cup of tea, just lethal dangerous with HV), before changing the PSU try to find out about 5V line in V and Amp to see if you have some peak/loss there.

Third, it’s not the +5V but the ground, … (check up to usb/pc cable)

logic issue: (do you need to reboot the K40 between each fail for restart? can give a clue same if you did it by precaution)
Another test you can do is to run jobs with no laser line (disconnect L), to check the M2 nano and see if it finish the job. (motor moves to end of gcode/homing).

last (very small probability and a bit complicated to see without K40 dismantling) does your stepper motors very hot ? (looking for any power peak in low V)

To sum up :
5V line issues a) overload b) HV perturbation c) moving ground value (5V-ground different from 5V).
Ground Issues…
Logic issue (5V & ground again -USB cable)

Oh my tomatsu! You struck gold! I have been down with complications from a spinal fluid leak but made myself get up and start to troubleshoot.

I checked the board as recommended and saw the inside cable was hot glued in and rocked slightly. I prised it off the board and removed the glue and re-attached it as best I can (the board has a clip but the connector is smooth). The machine completed a simple job straight away!

This is the first time it’s run successfully since the issues started!

I’ll aim to get upright and do some more trials over the weekend and reply to everyone who has offered help. Honestly you’ve all made me the happiest girl today! Thank you makerforums peeps! Thank you!

3 Likes

A+ quality control. :rofl:

Glad it’s working. The intermittent issues are the worst.

2 Likes

@gwen Should we call this “Solved”?

1 Like

Glad to hear you got it working again.

Pro tip: Hot glue can be easily removed with 99.9% IPA. IPA doesn’t actually dissolve the glue. It creeps under it via capillary action and releases it. 99.9% IPA is also used for removing flux residue from PCBs. It won’t damage the PCB, the cables, connectors, etc. (It does damage acrylic, though. Don’t use it or window cleaner to clean the acrylic window.)

Pure IPA also evaporates fairly quickly. It’s a very convenient option for removing hot glue from electronics.

99.9% IPA is also a good choice for cleaning the optics. It’s not quite as effective as acetone, but the fumes are less nauseating and it doesn’t eat through nitrile gloves.

3 Likes