K40 Whisperer on Raspberry Pi

Hi, I’m trying to upgrade my K40 to work from a standalone computer instead of using a laptop.

My plan is to use a raspberry Pi (3B in this case) attached to the case with a touch screen. Files will be passed by USB. The shed is outside of wifi range!

My template is this tutorial: https://www.novaspirit.com/2018/06/14/raspberry-pi-controlled-k40-laser-cutter/

Which uses version 0.19.

I’m trying to install v0.54 of K40 Whisperer, but have come across a couple of issues. The first being an error message “Unable to load Pyclipper library (Offset trace outline will not work without it”.

I’m no python expert, but I think it is installed… so don’t know why it is not ‘seeing it’?

The second issue is there are no jog/move controls? Is this normal?


Any suggestions much appreciated.

The jog buttons are removed to make room for the other buttons if the screen is very small.

Sounds like the pyclipper Python library is not installed. If is not required for the core functionality of K40 Whisperer but as the message states one feature will not be available.

(You can install Pyclipper using “pip install pyclipper”)



Hi Scorch,

Thanks for confirming the buttons are not meant to be there. That solves one issue!

Double checked the pyclipper, says it is installed, but same issue. I could try delete and try again or just ignore if it doesn’t impact the core functionality.


p.s. Thank you for a wonderful piece off software in the first place!

1 Like

Any chance this is a python 2 vs python 3 thing? Does Whisperer use Python 3? Maybe pip3 install pyclipper if so?

I had the same error and I followed this video and it all worked out. https://www.youtube.com/watch?v=sM9DfxEleb4