K40 Whisperer (manual jogging/moving the laser head within the software)

k40-whisperer
(Akai Coit) #1

So, this is the first time I have tried to use this feature in a while. I wanted to check a measurement and decided to use the jog buttons to do so. A few of them are non responsive as of V0.29 of the software: Top-Center (up) and entire bottom row (down-left, down, down-right). Another interesting thing I just found playing around with it a little more, if I jog to center or top-right, I can’t jog left unless I jog right first. When jogging to top-left, center, or top-right, it conciders that location the new 0,0 and goes no futher left. Since up and down don’t work, I can’t verify if that is the case for those as well. Going to check the site to see if there is a newer version released and respond back if this has been fixed in the newer release or not (if there is one).

(Scorch) #2

It sounds like your design is bigger that the workable area in the Y direction. K40 Whisperer has never allowed jogging that puts the design or laser head outside the laserable area.

If you want to visually measure something you can move the laser head independant of the design by using the right mouse button dragging on the grey dot.

If you tag me here I should get notified then you wouldn’t need to tag me in G+.

2 Likes
(Akai Coit) #3

Thanks for the note about tagging you here (hadn’t looked into that just yet, but wanted to make sure I notified you of the post). Where it confuses me and makes me wonder about your response is when the head is in the center of the area of the file being used. I still can’t go up or down. And the buttons to move to the bottom left and bottom right corners do not respond at all. I can freely go between center, top left and top right without any issues using the jog buttons. But even after reinitializing AND homing, the bottom row does not work at all. Conceptually, if I jog to the top right of the design that is currently open, I should be able to manually jog left back to the top left corner one click at a time, but I am unable to do that. If I use the top-right button, I am unable to manually go in any direction. When I use the center jog button, I am only able to manually go right (as up and down are not responsive, left becomes non-responsive at that point, but if I jog right from center, I am able to jog left BACK to the center point. It treats the center point as the new 0,0 coordinate).

My initial intent was to see where the bottom left corner was for a piece that I was imagining was outside of the laserable area. I wanted to find out how much bigger the piece was than the workable area so I could cut the blanks to size more accurately (I’ve been cutting plywood to fit the machine at a smaller than necessary size for some time and I wanted to remeasure things so I could know the exact maximum size I can work with given my current setup). When first initializing and homing the head, I was not able to use the bottom left jog button or the manual down button. From there, I started testing what I could and could not do. I will also try closing the program altogether, reopening and seeing what kind of jogging I am able to do at that point.

(Akai Coit) #4

So, I just tried opening a blank svg that was the full size of the bed of the machine. I initialized and homed the head, then played with the jog buttons a bit. If I used any of the buttons to jog to the corners or the center, the arrows became non-responsive, but not always. I’m very confused about what could be going on with this, so I suggest testing this, yourself, Scorch (not sure how the tagging works here just yet) and seeing what kind of response you get specifically from the buttons.

(Ray Kholodovsky) #5

Nice to see Mr. Scorch here.

6 Likes
(Scorch) #6

It won’t let you jog if your design is as big as the laser area because it won’t let you move the design outside the laser area. A design the size of the laser area takes a ton of resources because of the way K40 Whisperer handles raster data. That is why I always recomend reducing the page size as much ad possible in Inkscape.

1 Like
(Akai Coit) #7

So you’re saying that I can’t jog INSIDE of the design area? That would mean that jogging is basically pushing around the design? I will try this with no file loaded and see if it makes a difference.

(Scorch) #8

Yes, Jogging is basically pushing around the design.

You can jog within a design. To do this you need to hold down the ‘Alt’ and ‘Control’ keys and use the arrow keys to jog.

Or you can right click on the grey dot and drag it. (not jogging but moves the laser head)

1 Like
(Scorch) #9

I see your point about tagging. I assumed there was a way but I don’t see how to do it.

Edit: I figured it out. You just use the persons user name with an “@” symbol @CPUnltd

2 Likes
(Akai Coit) #10

So the “issue” was moreso a lack of understanding of the features involved. I changed the title to suit (for the most part) and am considering this just a conversation about how the jogging works for those who get a little lost.

2 Likes