K40 Whisperer Jobs do not Finish with M3-Nano


The M3 Nano is the next iteration of the Lihuiyu boards. It comes equipped with a PWM and a multiplexing multi-purpose button.

However one of the more important things is that the TASK_COMPLETE signal is 204.

This previously was only used for an error code when you told it FNSENSE or some trash like that and was the response for the challenge code (the device responds to A<serial number> with a 204 on success that then gets rehomed (to identify the machine by serial number) the serial number on the card is all lower-case MD5 hashed).

While I do not yet understand the M3-Nano PWM controls or the weird GPIO button bit, the fact that it’s using 204 (it uses this for all tasks complete, not simply things that terminate with FNSE but even jogs.



It matters because some people are already getting the device as a replacement or new device when they order an M2. And we’ll start seeing them in machines fairly soon (And really hopefully in software.

I ruled out every remaining letter HJKOQWXYZ in both compact and rapid modes). And the symbols within that row of the ascii table [\]^_ I would expect something like Q064 to trigger the PWM but no such luck.


(204 - After Jog)


Thanks for the info @Tatarize.

Last week as a temporary fix for this problem I added an option to K40 Whisperer V0.61 in the setting to disable waiting for the laser to finish. After I have a chance to test a permanent fix I will release a new version that recognizes the Nano M3 TASK_COMPLETE code.

The latest version of K40 Whisperer with the changes can be found here:


The multiplexing button during a run when triggered will stop the laser. It will either flicker between 232/236 or 200/204 (depending on the 32 bit – Busy). We figured it out after finding an ebay listing that had some additional information. It also suggested there was new software which we’re trying to hunt down. Also, if you opt to buy a board there’s blue M3 Nano Plus boards out there with TMC steppers rather than A4988s which is probably worth the extra five bucks, those are some nicer steppers.

We’ve tried a bunch of random stuff for the PWM but can’t seem to solve it, and are hunting for any new software to maybe allow that. I think it’s possible to trigger a software pause getting it stuck into 238 mode now (for MeerK40t this breaks things as it won’t send the hardware unpause without the 206 state).


Hi, I test the new version with the M3Nano board and it failed on this problem, it activated the laser after finishing the model. any idea on this?

No, I have no idea why that would happen. Sounds like there might be more different about the M3 than initially thought… or you may have an electrical problem that is causing the the laser to trigger.


1 Like

I thought about some electrical problems, but this behavior is not present with other software like Corel Laser and LaserDRW, we are very comfortable with K40 but now we can’t fix this issue.

Are saying that you have tested the Nano M3 with Laser Draw and Corel Laser?

Yes! it worked fine with these two guys!

What version of Laser Draw did you test with?

The version is 2013 0.2

The only real way to fire the laser without moving the laser is to send a D command in rapid mode. So like IDS1P for example will trigger a down event. But, I’ve not seen any indication that K40W sends that sort of command ever. There have been a few times things get sent into an error state and have locked things on but it was exceptionally rare. Most of the meerk40t devs have M3s now and I’ve not heard about them getting stuck on.

Did you hook up the PWM? There’s some instructions on that and how it’s supposed to work, but at most I think we hooked a voltmeter to it and ran through all the letters of the alphabet. I think there’s some chance even an M2 could lock state with an @ command between different commands but it was really sort of rare. Like issue of runaways (sometimes it would fly off a direction and just stay running in that direction, it’s largely the reason MeerK40t doesn’t use @nse much at all.

@Ramon_Rios thanks for reporting this issue (i.e. laser coming on after job). I got my hands on an M3 Nano.

The latest version of K40 Whisperer (V0.62) fixes the following issues:

  • The new job finished code with the M3 Nano is now detected.
  • The Laser no longer remains on while moving back to starting position after raster engraving with M3 Nano board

The latest version can be downloaded here: