K40 Whisperer crashes computer when I press "initialize laser cutter"

Hi, so I just bought a k40 and after a little while managed to get it up and running. Did a few test cuts I made on Inkscape, and everything was running smoothly. Didn’t touch it for a week, as work keeps me busy. But I just hooked my computer up to it as usual, loaded a new cut file in k40 whisper, but when I hit “initialize laser cutter” my computer crashes and is forced to restart, saying it needs to collect data on the crash.

I don’t know what’s going on with it, so I tried it a few times, shut it off, deleted the only software and downloaded it again, but it still crashes.

What can I do to fix it? Even pressing “initialize laser cutter” without a project loaded causes it to crash.


That is not good. I don’t know what would cause that, seems driver related. My only suggestion is to remove the diver:
https://www.scorchworks.com/K40whisperer/k40w_setup.html#windowsRemoveUSB

You could then try reinstalling. If the driver continues to be an issue you can switch to MeerK40t which can operate with the standard driver.

Scorch

2 Likes

Thank you for the advice Scorch. Unfortunately deleting the file and reinstalling it didn’t work. So now I think there may be an issue with my computer, since meerk40t caused it to do the same thing when I tried to run a cut. So sadly I think my “new” computer maybe on its way out, if it’s having the same issue with multiple programs.

If it’s a laptop then try running it without connecting to an AC outlet(battery powered). If it’s a desktop computer, try to connect your computer to the same electrical outlet the K40 is connected to. This could be the difference between then and now which could be a ground loop issue.

1 Like

A cheap solution is to run K40 on a raspberry pi

1 Like

Not as cheap as it used to be though. :sob:

3 Likes

[Raspberry Pi 4 Model B (4GB) https://amzn.eu/d/g5DraFZ](Raspberry Pi 4 Model B (4GB) https://amzn.eu/d/g5DraFZ)

I had no idea ! Pehaps i should sell mine - ive got loads of them lol

I have about two more projects that want RPi 4s than I possess at the moment, so I’ve been keeping an eye open. But I don’t expect the shortage to resolve very soon.