K40 Whisperer 0.54 on Raspberry Pi - USB Error

Hi all,

I’ve just unboxed my K40 and installed K40 whisperer on an old Raspberry Pi 2B with a fresh build of the Raspberry Pi OS. Similarly to @Martyn_D, I followed the Novaspirit guide, subbing out his links for 0.17 w/ 0.54.

I also followed another guide I came across while googling, which is roughly the same as the instructions in README_Linux.txt with a few extra hints and tips.

I’m running k40_whisperer.py with sudo, and I’m getting the error “USB Error: Unable to set USB Device configuration.”

This error seems to be associated with the user not having access to the USB device, but I set the udev rules as described in README_Linux.txt using my lsusb values (which I double-checked). Regardless, running as sudo should negate this USB permissions issue.

All the guides and help topics I’ve been able to find online for this error are solved by using sudo to overcome the USB permissions issue. This isn’t working for me though.

Any ideas?

1 Like

Which controller board do you have?


Not sure.

I solved this late yesterday though. I updated to 0.58 and I can initialise the printer now. I assume it was a driver issue, which looks to have been resolved in 0.56.

Thanks for your quick response though :+1: