K40 mks SBASE 1.3 and grbl lpc

Hi everyone I have installed the mks s base 1.3 card on my k40 it communicates the machine performs the movements.but when I perform the work with the help of the laser tube the machine stalls and I have to reset the card by clicking on the reset button. this problem occurs only when the laser beam is on, while if I send it to processing with the tube off, the machine ends the I work without problems. Can you help me? I’m going crazy. Via I attach photos of the links

Is this a picture of a working configuration?
I do not see AC power to the LPS?
Where does the black wire that comes from the LPS right-hand connector go?

How is the laser being controlled by the control board?

I would check/verify all power connections to the MKS are solid and then check/verify the common ground/negative wire between the MKS power supply and the LPS ground are solid.

Just a hunch but do you have a 5K or 10K POT controlling the voltage on LPS-IN as opposed to a 1K POT? I was having similar issues along with noticing my laser power was dropping when I enabled the laser(button ON). Found LPS 5V was sagging slightly when I hit the Laser Enable button and eventually replacing the POT with a 1K seemed to fix both problems. I don’t know why but maybe coincidence.

I managed to solve it by connecting a cable to the frame of the machine that connects to the input -24 of the mks and consequently to the psu of the pipe after this change the machine works Well. another question you recommend to set the ste to 1/16 or 1/32?

So as I understand it you added a ground connection from the LPS to the controller?
Is that correct?

1 Like

That’s what I got from it too only the ground was provided by using the chassis as the electrical conduit for the common ground.

If the above is true it would be better if you connected a ground wire from each of:

  • LPS
  • Controller

…to a common point in the frame.

I typically put a fastener in the frame and run a wire with a soldered ring tongue to that fastener with star washers between each of the ring tongues.



I did exactly as you said thanks for your help

So we can mark this “solved” ???

Yes, the problem has been solved