K40 Laser isn't working

Hello, I bought a Chinese laser machine from alibaba, and when I tried to test the laser it was not working. I tried to do the engraving using K40 Whisperer, but the laser was moving but not firing. Tbh, I don’t know much about laser machines and I don’t know what to do, I took a few pictures from inside to see if anyone knows what is the issue.

Thank you

Please post pictures showing
-Laser power supply connectors
-Control panel

1 Like

Do you have water flowing/circulating through the tube and a 3-5 gal bucket of water?

And you REALLY need to read all of this FAQ(K40 laser - buying - installing - upgrading - K40.se ) along with the entire K40 Intro on the top of this page you are on. New to K40: Start Here

Or else you’ll be back trying to read it with your one good remaining eye. :wink:

1 Like

Does the laser fire when you press the test button?

1 Like

you might want to clarify which Test button. There’s the one on the front panel(which we are still waiting for a picture of) and there’s the Test button on the Laser Power Supply(LPS). But before any forced firing, we need to be sure he has configured the machine for safe operation(ie water flowing for example).

1 Like

Yeah I was referring to the front panel before getting to the one on the LPS. But point taken about the rest. Just queuing up some questions.


This is the control panel

Can you please show me what the laser connectors looks like.

Thank you

I use this

This is the only thing I found available in my workshop.

Also, I have laser glasses to protect my eyes :wink:

Nothing, there’s just a red dot but no firing.

The Laser Power Supply (LPS) is a black box with a yellow triangular caution sticker on the top. It is in the bay under the control panel cover.

The connectors on that supply are green. A 6 pin and a 4 pin.

I need a picture of the front of the LPS.

What test button did you push? The one on the control panel or the one down on the LPS.

I took pictures of both sides

Push the red test button down on the LPS does the laser fire???

It’s not working, is something wrong with tube?

It’s best to answer the questions explicitly.

By it’s not working do you mean you pushed the test button on the LPS and it does not fire?

1 Like

Yes, I pressed the test button on the LPS and the laser doesn’t fire

Ok here are some questions that will help direct our troubleshooting:

  1. How old is this machine?
  2. Has this machine ever fired the laser?
  3. What is the power level setting [“current indication” on the control panel] set to when you pushed the LPS Test button.
  4. Do you have a digital volt meter and do you know how to use it?
  5. Did you contact the seller about this problem?
  6. When you push the LPS test button are there any sounds like crackling/hissing?
  7. When the LPS Test button is pushed is there any kind of light in the tube?

To verify:

  • Thoroughly check the tube for cracks in the glass. Is there any?

Please post a link to the page where you bought this machine

  1. I got it this June
  2. No
  3. I tried 20% and 60%
  4. I don’t have one and I don’t know how to use it
  5. Yes, he thinks it’s a software problem, I tried telling him that but he won’t listen
  6. No
  7. No

The tube is in perfect condition, here is a picture

This is the link to my machine

Thank you

Sorry to say this but the tube is broken… There should not be water in the outer portion of the tube(large diameter). Either it was fired without water or water running or it was broken in transport.


I couldn’t find any crack on the laser tube tho, what may cause this problem?

Thank you

The tube may have been shocked while in shipment and the damage (crack) may not be easy to see.

1 Like