K40 Laser firing isses

So, I got the homing issue fixed and now my K40 will not fire. I turned the water on and got the bubbles out and powered the machine on. It would actually go through the motions of engraving a square but when it finished there was not anything on the test board. I even tried the manual test switch but still nothing. Can someone help me, please?

Does the beam fire with the test button down on the LPS?
Please post a picture of:

  • Control panel
  • Laser Power supply input connectors

Hi, yes I tried the red test button on the LPS and it still won’t fire. I am including the pictures you ask for.

Can you see where these two wires are going? Maybe a water flow sensor?

This may sound obvious, but I would check this switch is working.

So with the power off, either check it with a multi meter, or disconnect it from the power supply and bridge the gap with another piece of wire.

Unless there is something unique about that LPS. The test button on the LPS overrides all the input controls i.e. P & L
If it does not fire using the switch down on the LPS then the LPS has a problem.

On the LPS:

  1. The green LED should be on if not check the input AC power
  2. Check the 5V output with a DVM.
  3. Check the 24VDC output with a DVM

For reference (ignore the Red lines for now)


ok I have done the test and have come to the conclusion that the 24 V is measuring at 5.36 V and the 5V is at .95 V. So what do I do now? Thanks for helping me.

Something does not make sense to me.
Your gantry will move but the 24V reads 5v??
Doesn’t seem likely the steppers will even work at 5V?

How and with what are you making these measurements?
Is the green LED on the LPS lit?

Try this:
Disconnect the rightmost 2 connectors (P2,P1)
Push the red test button on the LPS and see if the laser will fire.