K40 Laser digital display and buttons stopped working, doesn't fire

So we tried to modify our K40 with a Smoothieboard. This didn’t work so we had to rebuild to nano board as we have to laser something asap. But now the display for setting laser power and test firing etc isn’t showing anything, nor are the test buttons on PSU or control interface/display working. The board of the controls let’s current through and the cables going there let thorugh 5V. Any ideas what could be wrong? Thanks in advance!

It sounds like you have something wrong with 5V power from the LPS.

  • Disconnected 5V?
  • Disconnected ground?

Post pictures of:

  • Laser power supply (LPS) showing the connectors.
  • Control panel front
  • Control panel back
  • Your controller showing connectors

Do you have a DVM and know how to use it?

Here are the photos:

there are a lot of clamps but that’s so we could rebuild from smoothie to nano faster. (this worked also when we rebuilt it once) everything is connected back to the same wires as before, just with clamps between., All other 5V-stuff is orking (LED, laserpointer).

Also I have a DVM and know how to use, yes.

I did not mean the PCB but the actual front panel and then the wiring from the back.
Also, include the other photos requested.

What does the 5v read on the LPS and up on the Digital panel?

When you click the picture it should open the album with all photos on imgur or isn’t it?
Also on the LPS it reads 5V and on the Panel it’s also 5V.
EDIT: the test button on the LPS works when the display PCB is not connected and stops working when I connect it.

AH got it…

It acts as if the 5v to the control panel and/or ground it messed up.

I would check panel voltages relative to the ground on the LPS.
Reverify wiring with an ohmmeter.

Here is how it should be wired.

It’s wired exactly like that, also reverified with an ohmmeter, all good. The voltage from panel relative to ground on LPS shows 4.25V

Do I have this correct:

  • Segment display on panel does not light up.
  • No other LED’s on the panel light up.
  • The test button on the supply only works if you unplug the panel.

Is the power led on the LPS is on

The 5V supply should be closer to 5V that suggests to me the panel is over loading the supply.
If you unplug the panel does the 4.25 go closer to 5V?

If you got something like a lab bench power supply, take the panel out of the machine and see if it powers on if you hook up G and 5 V.

I just did that with mine (PowerLED 3.5). It draws about 30 mA. Like a caveman, I used female to female DuPont cables to connect to male to male DuPont cables in order to connect the alligator clips to the two pins of the JST connector. What a janky setup. Lol.

A replacement panel costs about $10. (Not all of them have that on/off button in the top right.)

Alternatively, replace it with a potentiometer, a momentary switch, and a (3-wire, 4+ digit) voltmeter if you want some kind of readout for the power value. While you’re at it, I recommend to install an ammeter if you haven’t done that already.

1 Like

Yes the segments don‘t light up and no buttons are working. Also no LEDs light up and the test button only works without the panel connected.
Messuring at the cable without the panel connected it‘ 5V.
Power LED on the LPS is lit.

Will try that thank you. We just ordered a new k40 because we need it asap. We will first try to connect the panel of the new one. If that works we can order a replacement and have two lasers. We can then also try to connect the smoothieboard to one without worrying about breaking it and not finishing orders lol.

Thanks alot for your help guys.
I hope I can, one day, also contribute to this awesome community.

1 Like