K40 laser cuts in very short arcs, even at low speeds

I have used a k40 with k40 whisperer for a few years.

It just started “backing up” very, very frequently, for any speeds in excess of 8 mm/s. As a result, it cuts in very short arcs with long-ish pauses or re-alignments between them. Ultimately, the quality of the cut is OK, but it takes 3-4 times as long, for all these restarts. It’s a little hard to describe; I tried uploading a video, but could not, as a new user.

I’ve read a bunch about stutter on this forum and others. I don’t think that’s what’s going on here – there’s no violent shaking or seemingly any jumps in the belt. But it seemed to be the closest “vocabulary” I could find.

Following those discussions, I tried tightening the x & y belts. I swapped my usual 20 ft usb cable with a 6ft shielded one with a ferrite collar / EMI filter, and plugged my laptop into the same power supply as the laser. That seemed to help a little bit (?) – I was able to cut a very simple star at 25 mm/s, with just a few of the stutters, but they were still three or four “resets.” The video is with that setup, cutting a design that I normally would not think twice about.

The most recent thing I cut was a raster engraving (on linoleum) – my first ever. That went fine. I don’t think this is related except possibly in the wear on the machine, and it’s the one unusual circumstance.

Any suggestions of things to check? Thanks for any help!!

You should be able to upload a video now. :relaxed:

Thanks – here it is! Any ideas?

Have you looked at the GCode… doh, K40Whisperer means you’re still using the M2Nano so it’s not a Gcode type operation. Had you updated your K40Whisperer lately? It looks really odd because it knows where it left off so it knows where to restart and it’s not losing steps or else it wouldn’t restart at the correct spot.

My guess is a change to K40Whisperer or a changed setting in K40whisperer might be causing this. So, if there is a saved config file/directory then I would try shutdown down K40Whisperer, renaming the config file, or directory to back it up, and then restart K40Whisperer and reconfigure then try again.

Do mention the OS version you are running and the version of Whisperer you have installed — I have no idea what’s wrong, but one of those might help @Scorch :relaxed:

It looks like something is causing the data tranfered over the USB cable to be slow. The laser is pausing and waiting for more data then it runs until it needs to wait for more data again.

I am not sure what would cause that to get worse over time. Could be the computer operating system causing delays, a loose connecton in the usb cable, electrical problem causing data to be corrupted on transfer requiring it to be re-sent.


Thanks very much, all, for the quick responses.

No recent updates to k40_whisperer; perhaps I changed something accidentally for the raster cut.

I will see if there are any jenky settings, but then keep debugging the data connection. Will report back once I’ve had time to work on this a bit more.

If you can test it with another laptop / computer if you have at hand may exclude issues with operating system , drivers of the motherboard of the pc/laptop and usb controller issues .

Maybe test with a different usb cable too. Usually they’re the same as what comes with an inkjet printer.

Thanks for the hints.

I had already tried three USB cables, so I switched to my Linux box (Ubuntu 20.04) and am back in business: cuts are normal & fast.

The (new) problem is persisting with the (very old) Mac laptop, but this gives me a solution.