K40 installation troubles

Hi everyone !

I am new to this forum, please excuse my english, it is not my native langage and i might do some mistakes. I just bought a k40 laser (Chrisun) and i hope that i could find some help. I am running windows 10 and want to install k40 whisperer in order to use .dxf files. I did not try to install the default software provided by the seller, i don’t have an optical player on my pc anyway…!

When i plugged the machine for the first time, it happened that :

  • When turning it on, i expected the head to go to home position but the motor keep running and bumping on the limit of the Y axe. The head does not move on the X axe.
  • When intalling K40 Whisperer, (by following the setup explanations on scorchworks) the installer can’t even find the machine. The machine is running (i unplugged the Y outpout on the motherboard to avoid bumping, tought i could reset home position directly on the software), the usb cable is connected on a usb slot that works fine with other devices (i tryed with other slots and an other cable, don’t fix the problem). I can’t finish the installation, it says “Cannot install. Laser device not found”. If i close the installation the software run properly, but of course does not operate the machine.

Is it normal that the motor limits are not correctly set by default ?
May i have a problem with the motherboard ? (It’s an M2 NANO)
Did i missed something obvious ?

I will be greatful for your ideas and advices, i’m behind my computer and can provide more info if needed.

Thank you all !

I have found this topic that presents kind of a similar problem :

But i my case nothing blocks the emitter/receiver unit to slide into the metal tabs at the endstop, and if i slide a screwdriver into it, it does not stop the movement on Y axis. I may have a problem with this emitter/receiver unit…

Also, i wonder if there might be a wrong plugged cable that could cause the k40 not to be recognized by my pc…

Still working on it. Thanks

Welcome to the forum!

The wires to that limit switch might be imperfectly connected or broken. Do you have a digital multimeter and know how to use it?

1 Like

Hi Michael,

Thank you for your answer !

I just solved this problem : You were right, the cable that leads to the motherboard was not correctly connected, i flipped it on the other side and now the head move fine on the Y and X axis.

Then i managed to properly install the drivers. So now the machine is running and recognized by K40 whisperer, step one completed ! Now looking for other problems propably incoming :stuck_out_tongue:

3 Likes

I have a brand new K40 that I am about to try and get going, and in mine the ribbon you have in your picture (with the red arrow) is just laying there, not hooked up! I was wondering what that was all about, now I am guessing it’s probably a problem…

2 Likes

Yep i don’t know if the head will even move with that cable unplugged…

I actually never tried it, luckily I noticed this post and realized the ribbon was important before I turned the laser on. I honestly thought maybe it was for a light. My other laser came with a cheap LED light ribbon in the housing that was useless. I guess the good side of the issues I had is they forced me to learn more about the machine, and it’s good to know more since I rely on the laser pretty heavily for a engraving a part I use in my business.

1 Like

The y-axis will still move since that motor is not on that cable. It will just run to the back and keep going. :grimacing:

See this recent vid.

1 Like