K40 engraving issue

Hi, I am new to laser cutter/engraving thingy, I have managed to align the mirrors, I can cut and engrave but the picture that engraves is that you can tell it something just not right there(I have not made a long test regarding the cutting). The picture quality is good but the whole picture is like being cut on multiple times and moved some to the left and some to the right side (horizontal).
Hopefully the upload is working.
![IMG_20200206_005327|375x500]
(upload://XifzVZVcR8NhicdcDpwdb97Ho1.jpeg)

Sometimes trying to move over the printing area and makes some worrisome noises.
Anyone do know how to fix this issue?

See yesterday’s post on a similar-looking problem:

Post your speeds and software you are using to make it easier for folks to help you.

I’m using CorelDraw software that is provided with the machine, speed were on 300mm/s, I did set down to 100mm/s and same issue so I tryed the next suggestion that is swapping USB cable and voila! Problem solved! Works how it is Intended.(for now)
Many thanks mcdanlj!!

2 Likes

Thanks for letting us know how you fixed it. Always good for other people who find this same issue.