Just wanted to let people know I had some weird behaviour with GRBL-LPC that

Just wanted to let people know I had some weird behaviour with GRBL-LPC that I don’t get with smoothie on a K40 running via C3D MINI, exactly the same engraving settings and the firmware settings were as similar as possible. Something, I think the power supply sometimes makes a worrying snapping noise, I thought at first this was the tube arcing through the coolant so did a tank change. Same result so switched back to smoothie and no noise. Noise came back when I reflashed GRBL-LPC so 99% sure its firmware related.

I am sticking with smoothie for now as I don’t know the cause of this fault and I’m scared of the very high voltage in these machines

  1. What is your PWM setting and is it the same for both configurations.
  2. What is in the coolant?
  3. What current and does current level have any effect on noise
  4. Does the laser current meter dance when the snapping noise if heard?

Somewhat strange that the supply “snapping” noise is different between configurations.
Don’t ignore the possibility that you have a failing supply and the change in noise is coincidental to the configuration. When these supplies fail sometimes they are intermittent.

You were right, just coincidental timing. Its an intermittent fault just had a snap while running smoothie. 1. 5000hz 2. distilled water no additives 3. Its set to be 11mA when I run a constant 100% beam but this was rastering with a range 0-60%. 4. It jumps.

So, I should get a new supply as a backup. Can you recommend. I also think I should be putting an additive into the water, are you still happy with aquarium algae treatment?

realise this is not laserweb related, sorry

watch your tube compartment as you run it, it very well may be arcing if its visibly jumping. if so, re-insulate the contacts well. I even put a piece of polycarb to block some screws near the positive end on mine as it wanted to jump to the screw near the ground stud. other than that I would agree with Don and think either current flowing to water or failing PSU

@oliver_jackson if you just hold the “test” button does it snap or only when engraving.
Turn out lights and check for arcs in the dark.
A video of the anode end of the tube while it snaps would be interesting.

Wild guessing its a supply going but other things can be the cause. In terms of a new supply, I just recommend getting the best deal on amazon of ebay with the same connectors.

I am happy with the algaecide but I do not use my machine heavily.

I’ve got guests here at the moment so I won’t get to record anything for a few days but I will try to get a recording. I did 10 minutes of only cutting last night and not a single snap. I’ve only had the machine a few months and have only just started rastering. I’m wondering if this has always been faulty but it wasn’t until the rapid on/off of rastering that it showed symptoms. Early next week I’m going to do some thorough experiments to see if it’s arcing in the tube or a failing supply, thanks for your help