Just loaded Chili Peppr and installed for my small DIY CNC engraver running on

Just loaded Chili Peppr and installed for my small DIY CNC engraver running on Arduino GRBL V 0.9 with CNC shield and Nema 23 1.9 Nm steppers and DRV8825 controllers and I’m trying to run Chili Peppr for the first time. My problem - all 3 Axes always display at zero regardless of position of motors whether manually moved by jog commands or by one of the example programs. Everything moves like it should with G-code sender and with Chili Peppr; it just does not display the current x,y,z coordinates of the tool. I’ve reloaded, rebooted, reconnected several times but no success. I’m assuming I have some software setting wrong that you have been asked about 1000 times but I could find nothing on the community/forum for this version of GRBL associated with this problem. I would welcome a response with the fix.
Thank You
KaDee

Which workspace are you using

Thanks for prompt response John.
I am using the GRBL work space for version V0.9. I tried the work space for version 1.1 also but it made no difference. Neither show any change in coordinates from zero.

Screenshots always help us debug. In particular I’d like to know what your serial port console shows you, especially with the filter funnel turned off to see if xyz coords are coming back.

I attached first screen shot. it will not allow me to attach more than 1 at a time. Also, please explain “Filter funnel”. I found the funnel that looks like one from Excel for filtering but it appears to do nothing.
missing/deleted image from Google+

missing/deleted image from Google+

Hmm, still can’t see the serial port console main content. If you collapse your Gcode widget so it’s small, that would give you screen real estate for the serial port console to show. Also, it looks like you’re using Firefox. You could try Chrome. You’re correct on the funnel icon looking like Excel.

I will have to download Chrome b4 I can retry. Its not on this Dell Laptop running Win 10 64Bit. But that is a good suggestion. I will try both it and Edge. I also found that I had the serial port set to “default” instead of GRBL. Changing it to GRBL did not help as the coordinates still do not change from zero, but it gives the zero coordinates proceeded by “NaN”. Here is latest screen shot showing the serial console window.
missing/deleted image from Google+

1.94 is latest serial port json server and you look like you’re on old one

ok, how do I get new one? I downloaded json server earier today?

BTW I tried running it from Microsoft Edge and it works just like it did on FireFox. I will try Chrome when it finishes loading. I just deleted and uninstalled Chrome yesterday due to its invasive nature so I’m having to reload it.

1.88 is probably fine actually, but the latest is on Github releases. https://github.com/chilipeppr/serial-port-json-server/releases

BTW, when I hear NaN it tends to mean folks need the Grbl 1.1 workspace.

I will go back to Github and look for this version and reload.
I have now reloaded Chrome, but it did not help. See screen shot. And, it still does the same thing so I tend not to think it is the web browser since I’ve tried Chrome, Fire Fox and Edge all performing exactly alike.
First, I will also try GRBL 1.1 work space again and get back to you.

THANK YOU John for staying with me and helping me diagnose the problem!
KaDee
missing/deleted image from Google+

I made quick test of V1.1 workspace. Sorry, but it did not help my main problem as the coordinates remain at zero. BUT, two things have changed under version 1.1. A) The “NaN” proceeding the zero for x,y,z coordinates is no longer displayed; B) The filter button now does something. It does appear to toggle the verbosity of output in the serial port console. But neither helped my main problem. Im going to go find the newer version of Json and I will be right back.

Sorry but none of these things have fixed the main problem, coordinates displayed are always zero even after the motors are observed to move both by jogging and by the example program.
I’m now on Chrome. I’m now running Ver 1.94 of Json. I’v tried toggling the filter. I’m on the GRBL Ver 1.1 work space. I’ve tried the GRBL Ver 0.9 work space. Ive done all these and rebooted and it still does not work.
I did just notice that the display does not follow the tool progression except in simulation mode. I thought it followed the tool as it executed the gcode. Perhaps it is not programmed to do so. Again, this is my first time to run the software. But, perhaps the new observation is related to the main problem.
missing/deleted image from Google+

Do you have any more ideas?

Four suggestions to help with debugging:

  1. In addition to turning the filter in the serial port console off also turn on verbose mode in the grbl console (the drop down menu in the grbl widget on the right)

  2. Also run sjps in verbose mode. You do this by adding a switch of -v to the execution command. Capture the output and post it here.

  3. Check the JavaScript console for errors.

  4. Specifically send ? to the controller via the serial port console.

Justin, as I originally said, I am brand new to Chill Peppr software and gcode. While I have written software code decades ago in numerous process, scientific, analyzer and older computer languages including counting cycles in PDP-11, 6502 and 8088 assembler and machine code, however I do not know how to do what you ask as there is nothing labeled nor are there intuitive icons associated with these tasks. For example, I have no idea what the accronym “sjps” means or which window is “Java script console.” Also, the “?” command entered into the serial port command console did nothing regardless if the filter is on or not. Thank you for assuming I was more up-to-date with current software; but at 61 I am badly outdated. Please tell me exactly what you want me to do based on that understanding and what I can see on my various windows or windows cmd structure. I am willing to do what you ask, please just give me instructions that are commensurate with the level of a newby.

Please don’t give up on me! I feel this software may do exactly what I want once I’ve gotten it fully operational and customized. Your patients is appreciated.

Thank You;
KaDee

I forgot to specifically state that I found the GRBL “widget” and have used the menu to turn on the verbose output mode so the instructions and responses are constantly being shown. What commands specifically do you want me to execute and capture that will give you insights? I have tried a couple rudimentary g-code commands and run and an example program and have seen no errors returned by GRBL. KaDee

well done @Kadee_Mccormick

I’d like to see a sample of the output shown in the serial widget on the left hand side please.

On the rest of the suggestions; assuming you are using chrome and assuming you are on the jpadie workspace:

  1. the grbl widget is on the right in the middle. it should say GRBL at the top left and then follow with the version number. If you click the down arrow to the right of that there will be a ‘Toggle verbose mode’ and ‘Toggle Debug Mode’. Please select both.

  2. the serial widget is on the left. it’s title is ‘Serial Port Console’. you can expand the box by clicking at the bottom and dragging the edge. you need to make sure that the filter is not on. the filter is the funnel icon.

  3. SPJS is serial port JSON server. it is the software that allows the browser to talk to the (virtual serial port). On windows you probably double click to start it. Instead right click and create a shortcut. In the short cut right click the properties and in the target add -v at the end of the command line but within any quotation marks. then to start SPJS double click on the shortcut. the output will be shown in a terminal window - you should be able to cut and paste it.

  4. the javascript console is available in chrome by clicking the three dots at the top right and selecting More Tools then Developer Tools. The select ‘Console’ and let us know whether there are any errors (they will be red).

the command to tell grbl to report on the current tool location is a question mark. You send the ? by typing into the box at the bottom of the serial port console. It should say ‘Type Serial port command’ in the absence of any entry. Then hit return.

If you are on grbl <1.0 then you should see some output like <IDLE,MPos:0.000 etc…> that’s what we are looking for.

My suspicion is that one of two things is happening. Either your SPJS install is a bit odd and believes that the status of the device is not changing and so it interrupts and does not send on the position data. The latest version of SPJS for windows is here: https://github.com/chilipeppr/serial-port-json-server/releases/download/v1.94/serial-port-json-server-1.94_windows_386.zip

the second suspicion is that there is something dodgy in the javascript somewhere that is bugging out the code before it can parse the display data from the drivers.

good luck!

By trial and error I think I figured out what you meant by “sjps”. I think it is the little program that runs in the background associated with the open com port. I made 2 screen prints while it was continuing to execute. Please tell me if you need something else on this item.
missing/deleted image from Google+