JSFiddle is still not smooth so far.

JSFiddle is still not smooth so far. It is making it hard for me to work on improving my widget.

I am trying to pass in the following requirejs config to chilipeppr

requirejs.config({
//To get timely, correct error triggers in IE, force a define/shim exports check.
enforceDefine: true,
paths: {
“inline:com-chilipeppr-elem-pubsubviewer”: [
http://fiddle.jshell.net/chilipeppr/zMbL9/show/light/”,
https://raw.githubusercontent.com/dattanchu/chilipepprGrblLaser/master/references/pubsubWidget.html
]
}
});

I was hoping to get requirejs automatic multi-source support to work. It seems that chilipeppr.load doesn’t take the above config. @jlauer am I misunderstanding the extent of requirejs.config that would affect the loading? I saw your other post on using requirejs.config to get my own javascript into my widget and thought this would just work.

JSFiddle is killing me today. It’s ruining my Chilipeppr’ing. It ruined @Riley_Porter_ril3y 's day too on ChiliPeppr. I tweeted them like 20 minutes ago to see if they can restart their servers. I will say they’ve been great for the last couple of weeks. Can you tweet them as well?

Hmm, let me go ahead and create a Twitter account for this. :expressionless: I read through the source of require.js and chilipeppr.load does not work with requirejs multiple paths. :frowning: I guess getting jsfiddle people to restart their server would be a good thing.

I am able to load ChiliPeppr right now. That http://fiddle.jshell.net/chilipeppr/zMbL9/show/light/ url is loading for me ok. Are you still not seeing it load for you? I’m just seeing I can’t save to JSFiddle right now, so I can’t update anything. I do have a cache of everything on Google App Engine which is where ChiliPeppr runs including if JSFiddle disappears off the planet, every time you do a forcerefresh=true I permanently store a copy of the file from JSFiddle.

As for that multi-source, I think that would work fine, but the problem is that Require.js won’t solve the fact that Github doesn’t serve that content up as true application/javascript content because they don’t want you to use them as a CDN. chilipeppr.load() does a proxy trick to allow that stuff. You could try to proxy your Github content through http://chilipeppr.com/geturl?url=(your raw github url) or there are some 3rd party proxies that will rewrite the header for you. This is partly why Github is not super ideal by the way.

The zMbL9 does load some time now but it is having problem with another one. Unl?? I think I will get some sleep early today :slight_smile:. Resume hacking tmr.